<!DOCTYPE html> <!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]--> <!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]--> <!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]--> <!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]--><head><meta charset="UTF-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="pingback" href="http://waterlandblog.com/xmlrpc.php" /> <!--[if lt IE 9]>
	<script src="http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-content/themes/Extra-2/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]--> <script>var et_site_url='http://waterlandblog.com';var et_post_id='137525';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script><title>Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home | The Waterland Blog</title><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%7COpen%20Sans%3A300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C400%2C300%2C600%2C700%2C800&#038;subset=latin%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="http://waterlandblog.com/wp-content/cache/min/1/112044c32c8312973a51986bc6a10dd7.css" data-minify="1" /><link rel="canonical" href="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/" /> <link rel='dns-prefetch' href='//cdn.broadstreetads.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Feed" href="http://waterlandblog.com/feed/" /><link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Comments Feed" href="http://waterlandblog.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="The Waterland Blog &raquo; iCal Feed" href="http://waterlandblog.com/events/?ical=1" /><link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home Comments Feed" href="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/feed/" /> <script type="text/javascript" data-cfasync="false">var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-7386995-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','http://waterlandblog.com/wp-content/cache/busting/google-tracking/ga-af5c617d36e28d19710b882a6824e213.js','__gaTracker');

		__gaTracker('create', 'UA-7386995-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script> <meta content="Extra v.2.27.4" name="generator" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style> <script type='text/javascript'>/* <![CDATA[ */ var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"http:\/\/waterlandblog.com","hash_tracking":"false"}; /* ]]> */</script> <script type='text/javascript' src='http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"http:\/\/waterlandblog.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"137525","token":"a4041707bc","debug":""}; /* ]]> */</script> <link rel='https://api.w.org/' href='http://waterlandblog.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://waterlandblog.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://waterlandblog.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='City of Des Moines&#8217; Summer Concert Series suspended through end of year' href='http://waterlandblog.com/2020/05/04/city-of-des-moines-summer-concert-series-suspended-through-end-of-year/' /><link rel='shortlink' href='http://waterlandblog.com/?p=137525' /><link rel="alternate" type="application/json+oembed" href="http://waterlandblog.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwaterlandblog.com%2F2020%2F05%2F05%2Frambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home%2F" /><link rel="alternate" type="text/xml+oembed" href="http://waterlandblog.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwaterlandblog.com%2F2020%2F05%2F05%2Frambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home%2F&#038;format=xml" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://waterlandblog.com"><link rel="https://theeventscalendar.com/" href="http://waterlandblog.com/wp-json/tribe/events/v1/" /><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body class="post-template-default single single-post postid-137525 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fullwidth_secondary_nav et_fixed_nav et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container"><header class="header left-right"><div id="top-header" style=""><div class="container"><div id="et-secondary-nav" class="et-trending"><div id="et-trending"> <a id="et-trending-button" href="#" title=""> <span></span> <span></span> <span></span> </a><h4 id="et-trending-label"> TRENDING:</h4><div id='et-trending-container'><div id="et-trending-post-137412" class="et-trending-post et-trending-latest"> <a href="http://waterlandblog.com/2020/04/15/letter-deputy-mayor-shares-comments-on-last-thursdays-council-meeting/">LETTER: Deputy Mayor shares his thoughts on last Thursd...</a></div><div id="et-trending-post-137495" class="et-trending-post"> <a href="http://waterlandblog.com/2020/04/30/letter-councilmember-martinelli-proposes-pandemic-relief-proposals-for-des-moines/">LETTER: Councilmember Martinelli shares pandemic relief...</a></div><div id="et-trending-post-137435" class="et-trending-post"> <a href="http://waterlandblog.com/2020/04/20/letter-councilmember-harris-responds-to-mayor-pina-councilmember-mahoney/">LETTER: Councilmember Harris responds to Mayor Pina &#0...</a></div></div></div></div><div id="et-info"><ul class="et-extra-social-icons" style=""><li class="et-extra-social-icon facebook"> <a href="https://facebook.com/waterlandblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a></li><li class="et-extra-social-icon twitter"> <a href="https://twitter.com/waterlandblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a></li><li class="et-extra-social-icon instagram"> <a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a></li></ul><div class="et-top-search" style=""><form role="search" class="et-search-form" method="get" action="http://waterlandblog.com/"> <input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" /> <button class="et-search-submit"></button></form></div></div></div></div><div id="main-header-wrapper"><div id="main-header" data-fixed-height="80"><div class="container"> <a class="logo" href="http://waterlandblog.com/" data-fixed-height="51"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="The Waterland Blog" id="logo" data-lazy-src="https://waterlandblog.wpengine.com/wp-content/uploads/2019/09/WLBlogoSKM19-SMALLER.png" /><noscript><img src="https://waterlandblog.wpengine.com/wp-content/uploads/2019/09/WLBlogoSKM19-SMALLER.png" alt="The Waterland Blog" id="logo" /></noscript> </a><div id="et-navigation" class=""><ul id="et-menu" class="nav"><li id="menu-item-135956" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135956"><a href="https://waterlandblog.wpengine.com/">Home</a></li><li id="menu-item-136289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136289"><a href="http://waterlandblog.com/advertise/">Advertise</a></li><li id="menu-item-136313" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136313"><a href="http://waterlandblog.com/coupons/">Coupons</a></li><li id="menu-item-135959" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135959"><a href="https://waterlandblog.wpengine.com/events/">Events</a></li><li id="menu-item-135957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-135957"><a href="http://waterlandblog.com/category/crime/">Crime</a></li><li id="menu-item-135958" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-135958"><a href="http://waterlandblog.com/category/business/">Business</a></li><li id="menu-item-135980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135980"><a href="http://waterlandblog.com/weather/">Weather</a></li><li id="menu-item-135981" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135981"><a href="http://waterlandblog.com/jobs/">Jobs</a></li><li id="menu-item-135984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-135984"><a href="http://waterlandblog.com/about/">About</a><ul class="sub-menu"><li id="menu-item-136284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136284"><a href="http://waterlandblog.com/about/">About</a></li><li id="menu-item-135982" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135982"><a href="http://waterlandblog.com/how-to-submit-to-the-blog/">How to submit</a></li><li id="menu-item-135983" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135983"><a href="http://waterlandblog.com/contact/">Contact</a></li></ul></li></ul><div id="et-mobile-navigation"> <span class="show-menu"><div class="show-menu-button"> <span></span> <span></span> <span></span></div><p>Select Page</p> </span><nav></nav></div></div></div></div></div></header><div id="main-content"><div class="container"><div id="content-area" class="clearfix"><div class="et_pb_extra_column_main"><article id="post-137525" class="module single-post-module post-137525 post type-post status-publish format-standard has-post-thumbnail hentry category-business category-des-moines category-featured-post category-news category-sponsored tag-ants tag-bedbugs tag-beetles tag-bugs tag-business tag-des-moines tag-fleas tag-insects tag-mice tag-news tag-pests tag-rambo-total-pest-control tag-rats tag-rodents tag-sponsored tag-termites tag-wood-boring-beetles et-has-post-format-content et_post_format-et-post-format-standard"><div class="post-header"><h1 class="entry-title">Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home</h1><div class="post-meta vcard"><p><span class="updated">May 5, 2020</span> | <a href="http://waterlandblog.com/category/business/" rel="tag">Business</a>, <a href="http://waterlandblog.com/category/des-moines/" rel="tag">Des Moines</a>, <a href="http://waterlandblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="http://waterlandblog.com/category/news/" rel="tag">News</a>, <a href="http://waterlandblog.com/category/sponsored/" rel="tag">Sponsored</a></p></div></div><div class="post-thumbnail header"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-lazy-src="http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-content/uploads/2020/05/SKM-RamboPestControlLogoRed-1280x640.jpg" /><noscript><img src="http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-content/uploads/2020/05/SKM-RamboPestControlLogoRed-1280x640.jpg" alt="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" /></noscript></div><div class="post-wrap"><div class="post-content entry-content"><blockquote><p><strong><u>SPONSORED</u>:</strong></p></blockquote><p><a href="https://b-townblog.com/wp-content/uploads/2020/04/RamboPesControlAnimAd2.gif"><img loading="lazy" class="size-full wp-image-146452 alignleft" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20250'%3E%3C/svg%3E" alt="" width="300" height="250" data-lazy-src="https://b-townblog.com/wp-content/uploads/2020/04/RamboPesControlAnimAd2.gif" /><noscript><img class="size-full wp-image-146452 alignleft" src="https://b-townblog.com/wp-content/uploads/2020/04/RamboPesControlAnimAd2.gif" alt="" width="300" height="250" /></noscript></a><br /> <strong>Welcome new Advertiser Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home!</strong></p><p>Ants, wood boring beetles, termites, bedbugs, fleas or the dreaded rodent or two do NOT make good roommates, especially during our &#8216;Stay Home, Stay Healthy&#8217; mandated time at home.</p><p>The good news is – you don’t need to wait for the orders to lift to rid your home of pests of most any sort.</p><p>What’s more, you can save 25% off regular rates for all initial services when you call our newest sponsor, Rambo Total Pest Control.</p><p>As a special recognition for our frontline healthcare workers and first responders, Rambo will even extend that discount to a generous <strong>50% off</strong>!</p><p>Now is an excellent time to get rid of those pests and save money while doing it.</p><p><a href="https://b-townblog.com/wp-content/uploads/2020/05/Rambo-Total-Pest-Control-Company-Owners.jpg"><img loading="lazy" class="wp-image-146599 alignright" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20204%20204'%3E%3C/svg%3E" alt="" width="204" height="204" data-lazy-src="https://b-townblog.com/wp-content/uploads/2020/05/Rambo-Total-Pest-Control-Company-Owners-300x300.jpg" /><noscript><img class="wp-image-146599 alignright" src="https://b-townblog.com/wp-content/uploads/2020/05/Rambo-Total-Pest-Control-Company-Owners-300x300.jpg" alt="" width="204" height="204" /></noscript></a>As an essential business for maintaining the sanitation and repair of your home, Rambo Total Pest Control is here to help. Operating from a central base in Puyallup, West Seattle native and West Seattle High alum Luke Rambo, wife Tera and their reliable team serve the greater Seattle area, including Burien, White Center, Normandy Park, Des Moines and all of South King County. Since their founding in 2007, they have been driven by a clear mission to provide all their customers clarity and detail, operate with discipline and follow through, while continually cultivating a hunger for knowledge. Luke and the team are guided by a vision of total customer satisfaction and you can count on them to work hard until your pest issue is eliminated and prevented from re-establishing.</p><p>But don’t just take our word for it, check their many five star reviews right here:</p><p style="text-align: center;"><strong><a href="http://www.pestreviews.org/companies/rambototalpest-puyallup" target="_blank" rel="noopener noreferrer">http://www.pestreviews.org/companies/rambototalpest-puyallup</a></strong></p><p>Including this awesome note from a Burien resident:</p><p style="padding-left: 40px;"><em>&#8220;Wow! I learned so much, and there was no hard-sell. Russ diagnosed the problem, got right to work on a multi-approach strategy to eliminate the insect infestation, and made a long-term plan with me to watch for and hinder any future problems. He was also fantastic at making sure the pets were safe from any treatment products being used. Thanks, Russ, and well done RAMBO! Also, Roxanna on the intake/crisis line is lovely, empathetic, and funny. Best to you!&#8221;</em></p><p>No matter what type of pest is bugging you, Rambo Total Pest Control has the experience and a well-honed process to help you get rid of them quickly.</p><p><strong>AND right now you can even save money!</strong></p><p>Click here to see the details of their Stay Pest Free specials:</p><p style="text-align: center;"><a href="https://rambopest.com/stay-home-stay-healthy-stay-pest-free/" target="_blank" rel="noopener noreferrer"><strong>https://rambopest.com/stay-home-stay-healthy-stay-pest-free/</strong></a></p><p>Then give them a call to schedule a service and say “Good riddance!” to pests in your home or business.</p><ul><li style="list-style-type: none;"><ul><li>Website: <a href="https://rambopest.com" target="_blank" rel="noopener noreferrer"><strong>https://rambopest.com</strong></a></li><li>Address: 4227 South Meridian Ste C-120, Puyallup WA 98373</li><li>Office Phone: <strong>(253) 848-6000</strong></li><li>Toll Free: <strong>(866) 540-RAMBO (7262)</strong></li><li>Email: <a href="/cdn-cgi/l/email-protection#c0a3afadada5aeb4b380b2a1ada2afb0a5b3b4eea3afad" target="_blank" rel="noopener noreferrer"><strong><span class="__cf_email__" data-cfemail="c8aba7a5a5ada6bcbb88baa9a5aaa7b8adbbbce6aba7a5">[email&#160;protected]</span></strong></a></li></ul></li></ul><link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"><style type="text/css">#mc_embed_signup{background:#fff;clear:left;font:14px Helvetica,Arial,sans-serif;width:100%}</style><div id="mc_embed_signup"><form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=9fe925a76f" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate><div id="mc_embed_signup_scroll"> <label for="mce-EMAIL">Get Des Moines WA news delivered FREE at 6pm daily via email:</label> <input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_9fe925a76f" tabindex="-1" value=""></div><div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div></div></form></div><div style="margin:5px auto; margin-bottom: 15px;"><broadstreet-zone zone-id="76232" keywords="not_home_page,not_landing_page,is_article_page,business,des-moines,featured-post,news,sponsored,rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><div instance-id="ac3b9f7f779ebeb4be90334ab49fde9e" street-address="269421"></div> </div></div><div class="post-footer"><div class="social-icons ed-social-share-icons"><p class="share-title">Share:</p> <a href="https://www.facebook.com/sharer.php?u=http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/&#038;t=Rambo%20Total%20Pest%20Control%20%E2%80%93%20SAVE%2025%25%20on%20local%2C%20honest%2C%20effective%20protection%20for%20a%20pest%20free%20home" class="social-share-link" title="Share &quot;Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home&quot; via Facebook" data-network-name="facebook" data-share-title="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-share-url="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/"> <span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span> </a><a href="https://twitter.com/intent/tweet?text=Rambo%20Total%20Pest%20Control%20%E2%80%93%20SAVE%2025%25%20on%20local%2C%20honest%2C%20effective%20protection%20for%20a%20pest%20free%20home%20http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/" class="social-share-link" title="Share &quot;Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home&quot; via Twitter" data-network-name="twitter" data-share-title="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-share-url="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/"> <span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span> </a><a href="https://plus.google.com/share?url=http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/&#038;t=Rambo%20Total%20Pest%20Control%20%E2%80%93%20SAVE%2025%25%20on%20local%2C%20honest%2C%20effective%20protection%20for%20a%20pest%20free%20home" class="social-share-link" title="Share &quot;Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home&quot; via Google +" data-network-name="googleplus" data-share-title="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-share-url="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/"> <span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover"></span> </a><a href="https://www.tumblr.com/share?v=3&#038;u=http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/&#038;t=Rambo%20Total%20Pest%20Control%20%E2%80%93%20SAVE%2025%25%20on%20local%2C%20honest%2C%20effective%20protection%20for%20a%20pest%20free%20home" class="social-share-link" title="Share &quot;Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home&quot; via Tumblr" data-network-name="tumblr" data-share-title="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-share-url="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/"> <span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover"></span> </a><a href="https://www.pinterest.com/pin/create/button/?url=http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/&#038;description=Rambo%20Total%20Pest%20Control%20%E2%80%93%20SAVE%2025%25%20on%20local%2C%20honest%2C%20effective%20protection%20for%20a%20pest%20free%20home&#038;media=http://waterlandblog.com/wp-content/uploads/2020/05/SKM-RamboPestControlLogoRed-150x150.jpg" class="social-share-link" title="Share &quot;Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home&quot; via Pinterest" data-network-name="pinterest" data-share-title="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-share-url="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/"> <span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover"></span> </a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/&#038;title=Rambo%20Total%20Pest%20Control%20%E2%80%93%20SAVE%2025%25%20on%20local%2C%20honest%2C%20effective%20protection%20for%20a%20pest%20free%20home" class="social-share-link" title="Share &quot;Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-share-url="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/"> <span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span> </a><a href="https://bufferapp.com/add?url=http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/&#038;title=Rambo%20Total%20Pest%20Control%20%E2%80%93%20SAVE%2025%25%20on%20local%2C%20honest%2C%20effective%20protection%20for%20a%20pest%20free%20home" class="social-share-link" title="Share &quot;Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home&quot; via Buffer" data-network-name="buffer" data-share-title="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-share-url="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/"> <span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover"></span> </a><a href="http://www.stumbleupon.com/badge?url=http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/&#038;title=Rambo%20Total%20Pest%20Control%20%E2%80%93%20SAVE%2025%25%20on%20local%2C%20honest%2C%20effective%20protection%20for%20a%20pest%20free%20home" class="social-share-link" title="Share &quot;Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-share-url="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/"> <span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover"></span> </a><a href="#" class="social-share-link" title="Share &quot;Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home&quot; via Email" data-network-name="basic_email" data-share-title="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-share-url="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/"> <span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span> </a><a href="#" class="social-share-link" title="Share &quot;Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home&quot; via Print" data-network-name="basic_print" data-share-title="Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home" data-share-url="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/"> <span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span> </a></div><style type="text/css" id="rating-stars">.post-footer .rating-stars #rated-stars img.star-on,.post-footer .rating-stars #rating-stars img.star-on{background-color:#366}</style></div><div class="et_pb_extra_row etad post_below"><div class="adsense-responsive-ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-2062216921302425" data-ad-slot="8599006172"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></article><nav class="post-nav"><div class="nav-links clearfix"><div class="nav-link nav-link-prev"> <a href="http://waterlandblog.com/2020/05/04/city-of-des-moines-summer-concert-series-suspended-through-end-of-year/" rel="prev"><span class="button">Previous</span><span class="title">City of Des Moines&#8217; Summer Concert Series suspended through end of year</span></a></div><div class="nav-link nav-link-next"></div></div></nav><section id="comment-wrap"><div id="comments" class="nocomments"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://waterlandblog.com/wp-comments-post.php?wpe-comment-post=waterlandblog" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='137525' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="af2379ca10" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="209" /></p></form></div></section></div><div class="et_pb_extra_column_sidebar"><div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle"></h4><form role="search" method="get" class="search-form" action="http://waterlandblog.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></div><div id="bs_zones-13" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76243" keywords="not_home_page,not_landing_page,is_article_page,business,des-moines,featured-post,news,sponsored,rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-17" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="78565" keywords="not_home_page,not_landing_page,is_article_page,business,des-moines,featured-post,news,sponsored,rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-5" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76249" keywords="not_home_page,not_landing_page,is_article_page,business,des-moines,featured-post,news,sponsored,rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-15" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76244" keywords="not_home_page,not_landing_page,is_article_page,business,des-moines,featured-post,news,sponsored,rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4><div class='weather-atlas-wrapper' style='background:#006699;border:1px solid #005588;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #005588'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Des Moines</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-11'></i><span class='temp'>45°</span><div class='current_text'>Rain Shower</div><div class='sunrise_sunset'>07:18<i class='wi wi-fw wi-weather-32'></i>17:28 PST</div></div><span class='current_text_2'>Feels like: 45<small>°F</small><br />Wind: 3<small>mph</small> SSE<br />Humidity: 97<small>%</small><br />Pressure: 30.28<small>"Hg</small><br />UV index: 0</span><div class='daily days' style='border-bottom:1px solid #005588'><span class='extended_day extended_day_1'>Tue</span><span class='extended_day extended_day_2'>Wed</span><span class='extended_day extended_day_3'>Thu</span></div><div class='daily'><span class='extended_day extended_day_1' title='Showers'>min 41<small>°F</small><br /><i class='wi wi-fw wi-weather-11'></i></span><span class='extended_day extended_day_2' title='Partly Cloudy'>49/39<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span><span class='extended_day extended_day_3' title='Showers'>46/40<small>°F</small><br /><i class='wi wi-fw wi-weather-11'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #005588'><a href='https://www.weather-us.com/en/washington-usa/des-moines' title='Weather Atlas - Weather forecast Des Moines, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Des Moines, Washington &#9656;</span></a></div></div></div><div id="bs_zones-6" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76246" keywords="not_home_page,not_landing_page,is_article_page,business,des-moines,featured-post,news,sponsored,rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-14" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="72685" keywords="not_home_page,not_landing_page,is_article_page,business,des-moines,featured-post,news,sponsored,rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home,post" soft-keywords="true" zone-alias="prime3"></broadstreet-zone></div></div><div id="bs_zones-10" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76235" keywords="not_home_page,not_landing_page,is_article_page,business,des-moines,featured-post,news,sponsored,rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="recent-posts-2" class="et_pb_widget widget_recent_entries"><h4 class="widgettitle">Recent Posts</h4><ul><li> <a href="http://waterlandblog.com/2020/05/05/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/" aria-current="page">Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home</a></li><li> <a href="http://waterlandblog.com/2020/05/04/city-of-des-moines-summer-concert-series-suspended-through-end-of-year/">City of Des Moines&#8217; Summer Concert Series suspended through end of year</a></li><li> <a href="http://waterlandblog.com/2020/05/04/settlement-reached-in-lawsuit-over-death-of-seattle-police-officers-son-in-des-moines/">Settlement reached in lawsuit over death of Seattle police officer’s son in Des Moines</a></li><li> <a href="http://waterlandblog.com/2020/05/04/video-blog-columnist-cassidy-huff-appears-in-john-krasinkis-some-good-news-6/">VIDEO: Blog Columnist Cassidy Huff appears in John Krasinki&#8217;s &#8216;Some Good News&#8217; #6</a></li><li> <a href="http://waterlandblog.com/2020/05/02/daily-dose-of-natural-beauty-occold-shield-fancy-leaf-geraniums-offer-interesting-backstory/">Daily Dose of Natural Beauty: Occold Shield Fancy Leaf Geraniums offer interesting backstory</a></li></ul></div><div id="zoom-social-icons-widget-2" class="et_pb_widget zoom-social-icons-widget"><h4 class="widgettitle">Follow us</h4><ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center"><li class="zoom-social_icons-list__item"> <a class="zoom-social_icons-list__link" href="https://facebook.com/waterlandblog" target="_blank"> <span class="zoom-social_icons-list-span socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 24px; padding:4px"></span> <span class="zoom-social_icons-list__label">Facebook</span> </a></li><li class="zoom-social_icons-list__item"> <a class="zoom-social_icons-list__link" href="https://twitter.com/waterlandblog" target="_blank"> <span class="zoom-social_icons-list-span socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#55acee" style="background-color : #55acee; font-size: 24px; padding:4px"></span> <span class="zoom-social_icons-list__label">Twitter</span> </a></li><li class="zoom-social_icons-list__item"> <a class="zoom-social_icons-list__link" href="https://www.youtube.com/channel/UCfavFUPHY9UUl2WdzwXi9cg" target="_blank"> <span class="zoom-social_icons-list-span socicon socicon-youtube" data-hover-rule="background-color" data-hover-color="#e02a20" style="background-color : #e02a20; font-size: 24px; padding:4px"></span> <span class="zoom-social_icons-list__label">YouTube</span> </a></li></ul></div><div id="et_ads-3" class="et_pb_widget widget_et_ads"><div class="widget_content clearfix"><div class="etad"> <a href="http://desmoinesumc.org" target="_blank"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Des Moines United Methodist Church" data-lazy-src="https://waterlandblog.com/wp-content/uploads/2019/11/DMUMC300x250Ad-1.jpg" /><noscript><img src="https://waterlandblog.com/wp-content/uploads/2019/11/DMUMC300x250Ad-1.jpg" alt="Des Moines United Methodist Church" /></noscript> </a></div></div></div><div id="wpp-2" class="et_pb_widget popular-posts"><h4 class="widgettitle">Popular Posts</h4><ul class="wpp-list"><li> <a href="http://waterlandblog.com/2020/02/15/two-teachers-forced-out-of-buriens-kennedy-catholic-high-school-due-to-lgbt-status/" class="wpp-post-title" target="_self">Two teachers forced out of Burien&#8217;s Kennedy Catholic High School due to LGBT status</a> <span class="wpp-meta post-stats"><span class="wpp-views">4,395 views</span></span></li><li> <a href="http://waterlandblog.com/2019/08/27/looks-like-the-historic-landmark-on-the-sound-has-been-sold/" class="wpp-post-title" target="_self">Looks like the historic Landmark on the Sound has been sold</a> <span class="wpp-meta post-stats"><span class="wpp-views">4,057 views</span></span></li><li> <a href="http://waterlandblog.com/2019/10/27/suspect-wanted-in-connection-with-sexual-assault-found-dead-in-des-moines-creek/" class="wpp-post-title" target="_self">Suspect wanted in connection with sexual assault found dead in Des Moines Creek</a> <span class="wpp-meta post-stats"><span class="wpp-views">3,427 views</span></span></li><li> <a href="http://waterlandblog.com/2019/10/12/city-of-des-moines-announces-end-of-criminal-probe-into-actions-of-legacy-foundation/" class="wpp-post-title" target="_self">City of Des Moines announces end of criminal probe into actions of Legacy Foundation</a> <span class="wpp-meta post-stats"><span class="wpp-views">2,474 views</span></span></li><li> <a href="http://waterlandblog.com/2019/12/20/landslide-closes-woodmont-drive-s-at-marine-view-drive-s-friday/" class="wpp-post-title" target="_self">Landslide closes Woodmont Drive S. at Marine View Drive S. Friday</a> <span class="wpp-meta post-stats"><span class="wpp-views">2,236 views</span></span></li><li> <a href="http://waterlandblog.com/2020/03/25/support-local-restaurants-during-the-quarantine-heres-a-take-out-directory/" class="wpp-post-title" target="_self">Support local restaurants during the quarantine – here&#8217;s a Take Out Directory</a> <span class="wpp-meta post-stats"><span class="wpp-views">1,745 views</span></span></li><li> <a href="http://waterlandblog.com/2019/12/21/saltwater-state-park-closed-due-to-sewage-spill-discharge/" class="wpp-post-title" target="_self">Saltwater State Park closed due to sewage spill discharge</a> <span class="wpp-meta post-stats"><span class="wpp-views">1,509 views</span></span></li><li> <a href="http://waterlandblog.com/2019/11/14/man-struck-killed-by-car-on-pacific-highway-s-early-thurs-morning/" class="wpp-post-title" target="_self">Man struck, killed by car on Pacific Highway S. early Thurs. morning</a> <span class="wpp-meta post-stats"><span class="wpp-views">1,461 views</span></span></li><li> <a href="http://waterlandblog.com/2020/02/03/here-are-the-8-residents-visions-for-taking-over-vacant-des-moines-council-seat/" class="wpp-post-title" target="_self">Here are the 8 residents &#038; &#8216;visions&#8217; for taking over vacant Des Moines Council seat</a> <span class="wpp-meta post-stats"><span class="wpp-views">1,393 views</span></span></li><li> <a href="http://waterlandblog.com/2019/10/30/mt-rainier-high-put-into-lockdown-wednesday-due-to-report-of-gun-in-backpack/" class="wpp-post-title" target="_self">Mt. Rainier High put into lockdown Wednesday due to report of gun in backpack</a> <span class="wpp-meta post-stats"><span class="wpp-views">1,392 views</span></span></li></ul></div><div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">pat nardo</span> on <a href="http://waterlandblog.com/2020/04/30/new-city-program-will-assist-seniors-veterans-and-local-businesses-during-pandemic/#comment-12205">New city program will assist seniors, veterans and local businesses during pandemic</a></li><li class="recentcomments"><span class="comment-author-link">pat nardo</span> on <a href="http://waterlandblog.com/2020/04/30/new-city-program-will-assist-seniors-veterans-and-local-businesses-during-pandemic/#comment-12117">New city program will assist seniors, veterans and local businesses during pandemic</a></li><li class="recentcomments"><span class="comment-author-link">Terry A.</span> on <a href="http://waterlandblog.com/2020/04/15/letter-deputy-mayor-shares-comments-on-last-thursdays-council-meeting/#comment-12115">LETTER: Deputy Mayor shares his thoughts on last Thursday&#8217;s council meeting</a></li><li class="recentcomments"><span class="comment-author-link">Mike</span> on <a href="http://waterlandblog.com/2020/04/30/letter-councilmember-martinelli-proposes-pandemic-relief-proposals-for-des-moines/#comment-12102">LETTER: Councilmember Martinelli shares pandemic relief proposals for Des Moines</a></li><li class="recentcomments"><span class="comment-author-link">mike</span> on <a href="http://waterlandblog.com/2020/04/13/des-moines-financial-condition-high-councilmember-challenged-for-negative-comments/#comment-12101">Des Moines’ financial condition high; Councilmember challenged for negative comments</a></li></ul></div><div id="bs_zones-12" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76241" keywords="not_home_page,not_landing_page,is_article_page,business,des-moines,featured-post,news,sponsored,rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div></div></div></div></div><footer id="footer" class="footer_columns_3"><div class="container"><div class="et_pb_extra_row container-width-change-notify"><div class="et_pb_extra_column odd column-1"><div id="rss-2" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget" href="http://b-townblog.com/feed"><img loading="lazy" class="rss-widget-icon" style="border:0" width="14" height="14" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2014%2014'%3E%3C/svg%3E" alt="RSS" data-lazy-src="http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-includes/images/rss.png" /><noscript><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-includes/images/rss.png" alt="RSS" /></noscript></a> <a class="rsswidget" href="https://b-townblog.com/">The B-Town (Burien) Blog</a></h4><ul><li><a class='rsswidget' href='https://b-townblog.com/2020/05/04/police-arrest-18-year-old-man-suspected-of-shooting-16-year-old-in-face-in-burien/'>Police arrest 18-year old man suspected of shooting 16-year old in face in Burien</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/05/04/rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home/'>Rambo Total Pest Control – SAVE 25% on local, honest, effective protection for a pest free home</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/05/04/last-call-dedicate-a-hanging-flower-basket-to-mom-for-mothers-day/'>LAST CALL: Dedicate a Hanging Flower Basket to Mom for Mother’s Day!</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/05/04/letter-8/'>LETTER: ‘How to Make Sense of What We Read, See, and Hear’</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/05/04/leading-burien-businesses-team-up-to-make-moms-day-unforgettable/'>Leading Burien businesses team up to make Mother’s Day unforgettable</a></li></ul></div></div><div class="et_pb_extra_column even column-2"><div id="rss-4" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget" href="http://ilovekent.net/feed"><img loading="lazy" class="rss-widget-icon" style="border:0" width="14" height="14" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2014%2014'%3E%3C/svg%3E" alt="RSS" data-lazy-src="http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-includes/images/rss.png" /><noscript><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-includes/images/rss.png" alt="RSS" /></noscript></a> <a class="rsswidget" href="https://www.ilovekent.net/">I Love Kent</a></h4><ul><li><a class='rsswidget' href='https://www.ilovekent.net/2020/05/04/givebig-and-help-the-kent-youth-orchestra/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=givebig-and-help-the-kent-youth-orchestra'>GiveBIG and help the Kent Youth Orchestra</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/05/02/covid-19-update-27-deaths-511-positives-in-kent-as-of-may-2-2020/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=covid-19-update-27-deaths-511-positives-in-kent-as-of-may-2-2020'>COVID-19 UPDATE: 27 deaths, 511 positives in Kent as of May 2, 2020</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/05/01/gov-inslee-extends-stay-home-stay-healthy-order-to-may-31/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=gov-inslee-extends-stay-home-stay-healthy-order-to-may-31'>Gov. Inslee extends ‘Stay Home, Stay Healthy’ order to May 31</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/05/01/congressman-adam-smith-visits-northwest-harvest-food-distribution-center-in-kent/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=congressman-adam-smith-visits-northwest-harvest-food-distribution-center-in-kent'>Congressman Adam Smith visits Northwest Harvest Food Distribution Center in Kent</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/05/01/riverbend-golf-complex-will-re-open-on-tuesday-may-5-%E2%9B%B3/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=riverbend-golf-complex-will-re-open-on-tuesday-may-5-%25e2%259b%25b3'>Riverbend Golf Complex will re-open on Tuesday, May 5 ⛳</a></li></ul></div></div><div class="et_pb_extra_column even column-4"><div id="rss-3" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget" href="http://seatacblog.com/feed"><img loading="lazy" class="rss-widget-icon" style="border:0" width="14" height="14" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2014%2014'%3E%3C/svg%3E" alt="RSS" data-lazy-src="http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-includes/images/rss.png" /><noscript><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-includes/images/rss.png" alt="RSS" /></noscript></a> <a class="rsswidget" href="https://seatacblog.com/">The SeaTac Blog</a></h4><ul><li><a class='rsswidget' href='https://seatacblog.com/2020/05/04/video-car-fire-quickly-extinguished-by-puget-sound-fire-sunday-night/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=video-car-fire-quickly-extinguished-by-puget-sound-fire-sunday-night'>VIDEO: Car fire quickly extinguished by Puget Sound Fire Sunday night</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/05/02/kitchen-worker-at-highline-public-schools-tests-positive-for-covid-19/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=kitchen-worker-at-highline-public-schools-tests-positive-for-covid-19'>Kitchen worker at Highline Public Schools tests positive for COVID-19</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/05/01/gov-inslee-extends-stay-home-stay-healthy-order-to-may-31/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=gov-inslee-extends-stay-home-stay-healthy-order-to-may-31'>Gov. Inslee extends ‘Stay Home, Stay Healthy’ order to May 31</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/05/01/jetstream-music-festival-will-feature-airport-musicians-online-on-wed-may-6/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=jetstream-music-festival-will-feature-airport-musicians-online-on-wed-may-6'>JetStream Music Festival will feature airport musicians online on Wed., May 6</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/05/01/berkshire-hathaway-homeservices-northwest-real-estate-agent-dianna-hinderlie-supports-local-biz/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=berkshire-hathaway-homeservices-northwest-real-estate-agent-dianna-hinderlie-supports-local-biz'>Berkshire Hathaway HomeServices Northwest Real Estate agent Dianna Hinderlie supports local biz</a></li></ul></div></div></div></div><div id="footer-bottom"><div class="container"><p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p><div id="footer-nav"><ul class="et-extra-social-icons" style=""><li class="et-extra-social-icon facebook"> <a href="https://facebook.com/waterlandblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a></li><li class="et-extra-social-icon twitter"> <a href="https://twitter.com/waterlandblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a></li><li class="et-extra-social-icon instagram"> <a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a></li></ul></div></div></div></footer></div> <script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','business','des-moines','featured-post','news','sponsored','rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home','post']</script> <script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["business","des-moines","featured-post","news","sponsored","rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home","post"],"url":"rambo-total-pest-control-save-25-on-local-honest-effective-protection-for-a-pest-free-home"};</script> <script type='text/javascript'>/* <![CDATA[ */ var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var EXTRA = {"images_uri":"http:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/images\/","ajaxurl":"http:\/\/waterlandblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"5c32bb980c","timeline_nonce":"8d09b040ab","blog_feed_nonce":"d3ae4e3c9a","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"http:\/\/waterlandblog.com\/wp-admin\/admin-ajax.php","images_uri":"http:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/images","builder_images_uri":"http:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/includes\/builder\/images","et_frontend_nonce":"9c796bfcab","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"aa379d9e27","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"137525","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = []; /* ]]> */</script> <script>window.lazyLoadOptions = {
                elements_selector: "[loading=lazy],.rocket-lazyload",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                },
use_native: true};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;
        
            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;
                            
                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );
                
                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };
                
                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="http://4c4eer3u8pco1vqb7xymfnl1.wpengine.netdna-cdn.com/wp-content/plugins/rocket-lazy-load/assets/js/12.0/lazyload.min.js"></script><script src="http://waterlandblog.com/wp-content/cache/min/1/c612b8d6347a2c7a25dfbae9703d975b.js" data-minify="1" defer></script></body></html>
