<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="http://waterlandblog.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="http://waterlandblog.com/wp-content/themes/Extra-2/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script>var et_site_url='http://waterlandblog.com';var et_post_id='138180';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31 | The Waterland Blog</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://fonts.googleapis.com/css?family=Open%20Sans%7COpen%20Sans%3A300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C400%2C300%2C600%2C700%2C800&#038;subset=latin%2Clatin-ext&#038;display=swap" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" href="http://waterlandblog.com/wp-content/cache/min/1/a3e2107a8bf0229f95a86077c25366c8.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" />

<link rel="canonical" href="http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/" />

<link rel='dns-prefetch' href='//cdn.bibblio.org' />
<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Feed" href="http://waterlandblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Comments Feed" href="http://waterlandblog.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The Waterland Blog &raquo; iCal Feed" href="http://waterlandblog.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31 Comments Feed" href="http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/feed/" />

<script type="text/javascript" data-cfasync="false">
    (window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
	var mi_version         = '7.12.3';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-7386995-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','http://waterlandblog.com/wp-content/cache/busting/google-tracking/ga-1e3ad19b0836d257e66df0e4106af582.js','__gaTracker');

		__gaTracker('create', 'UA-7386995-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>

<meta content="Extra v.2.27.4" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"http:\/\/waterlandblog.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":138180,"token":"a752a2bc4e","lang":0,"debug":0}
</script>
<link rel="https://api.w.org/" href="http://waterlandblog.com/wp-json/" /><link rel="alternate" type="application/json" href="http://waterlandblog.com/wp-json/wp/v2/posts/138180" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://waterlandblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://waterlandblog.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Highline Public Schools will remain in full Distance Learning for first semester' href='http://waterlandblog.com/2020/10/09/highline-public-schools-will-remain-in-full-distance-learning-for-first-semester/' />
<link rel='shortlink' href='http://waterlandblog.com/?p=138180' />
<link rel="alternate" type="application/json+oembed" href="http://waterlandblog.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwaterlandblog.com%2F2020%2F10%2F10%2Ffall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://waterlandblog.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwaterlandblog.com%2F2020%2F10%2F10%2Ffall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://waterlandblog.com"><link rel="https://theeventscalendar.com/" href="http://waterlandblog.com/wp-json/tribe/events/v1/" /><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />
<div id="pp-banner"></div><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>
<body class="post-template-default single single-post postid-138180 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fullwidth_secondary_nav et_fixed_nav et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="et-trending">

<div id="et-trending">

<a id="et-trending-button" href="#" title="">
<span></span>
<span></span>
<span></span>
</a>

<h4 id="et-trending-label">
TRENDING: </h4>

<div id='et-trending-container'>
<div id="et-trending-post-57034" class="et-trending-post et-trending-latest">
<a href="http://waterlandblog.com/2015/11/13/mayor-lashes-out-at-new-seatac-councilmembers-for-lecturing-city/">Mayor lashes out at new SeaTac Councilmembers for lectu...</a>
</div>
<div id="et-trending-post-56236" class="et-trending-post">
<a href="http://waterlandblog.com/2015/09/11/council-tells-objectors-we-do-care-while-city-works-to-movemitigate-drug-clinic/">Council tells objectors ‘we do care’ while city works t...</a>
</div>
<div id="et-trending-post-50478" class="et-trending-post">
<a href="http://waterlandblog.com/2013/10/22/letter-reader-submits-political-cartoon-about-city-council-election/">LETTER: Reader submits political cartoon about City Cou...</a>
</div>
</div>
</div>
</div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/waterlandblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/waterlandblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
</ul>

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="http://waterlandblog.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="80">
<div class="container">


<a class="logo" href="http://waterlandblog.com/" data-fixed-height="51">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="The Waterland Blog" id="logo" data-lazy-src="https://waterlandblog.wpengine.com/wp-content/uploads/2019/09/WLBlogoSKM19-SMALLER.png" /><noscript><img src="https://waterlandblog.wpengine.com/wp-content/uploads/2019/09/WLBlogoSKM19-SMALLER.png" alt="The Waterland Blog" id="logo" /></noscript>
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-135956" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135956"><a href="https://waterlandblog.wpengine.com/">Home</a></li>
<li id="menu-item-137601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137601"><a href="http://waterlandblog.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-135957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-135957"><a href="http://waterlandblog.com/category/crime/">Crime</a></li>
<li id="menu-item-135958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-135958"><a href="http://waterlandblog.com/category/business/">Business</a></li>
<li id="menu-item-135959" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135959"><a href="https://waterlandblog.wpengine.com/events/">Events</a></li>
<li id="menu-item-135981" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135981"><a href="http://waterlandblog.com/jobs/">Jobs</a></li>
<li id="menu-item-135980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135980"><a href="http://waterlandblog.com/weather/">Weather</a></li>
<li id="menu-item-136313" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136313"><a href="http://waterlandblog.com/coupons/">Coupons</a></li>
<li id="menu-item-136289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136289"><a href="http://waterlandblog.com/advertise/">Advertise</a></li>
<li id="menu-item-135984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-135984"><a href="http://waterlandblog.com/about/">About</a>
<ul class="sub-menu">
<li id="menu-item-136284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136284"><a href="http://waterlandblog.com/about/">About</a></li>
<li id="menu-item-135982" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135982"><a href="http://waterlandblog.com/how-to-submit-to-the-blog/">How to submit</a></li>
<li id="menu-item-135983" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135983"><a href="http://waterlandblog.com/contact/">Contact</a></li>
</ul>
</li>
</ul>  <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-138180" class="module single-post-module post-138180 post type-post status-publish format-standard has-post-thumbnail hentry category-des-moines category-environment category-events category-featured-post category-news tag-city-of-des-moines tag-des-moines tag-des-moines-marina tag-ecology tag-environment tag-news tag-recycle tag-recycle-event tag-recycling et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31</h1>
<div class="post-meta vcard">
<p><span class="updated">Oct 10, 2020</span> | <a href="http://waterlandblog.com/category/des-moines/" rel="tag">Des Moines</a>, <a href="http://waterlandblog.com/category/environment/" rel="tag">Environment</a>, <a href="http://waterlandblog.com/category/events/" rel="tag">Events</a>, <a href="http://waterlandblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="http://waterlandblog.com/category/news/" rel="tag">News</a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31" data-lazy-src="http://waterlandblog.com/wp-content/uploads/2020/10/WLB-DMRecyclingEvent103120-1280x640.jpg" /><noscript><img src="http://waterlandblog.com/wp-content/uploads/2020/10/WLB-DMRecyclingEvent103120-1280x640.jpg" alt="Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31" /></noscript> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p><strong>A Fall Recycling Collection Event will be held on Saturday, Oct. 31, 2020, from 9 a.m. – 3 p.m. at the Des Moines Marina.</strong></p>
<p>You Can Bring (<strong><a href="http://www.desmoineswa.gov/DocumentCenter/View/5166/2020-DM-Fall-RCE-Flyer?fbclid=IwAR2_rwAVdlo0B3WpVu8srJ3QYko4Nwnf3lH2z1yp9NqTIIXxncbfP6-1kQM" target="_blank" rel="noopener noreferrer">download PDF flyer here</a></strong>):</p>
<ul>
<li style="list-style-type: none;">
<ul>
<li>Electronic/Computer Equipment &#8211; no fee</li>
<li>TV Sets &#8211; no fee</li>
<li>Tires &#8211; fees apply</li>
<li>Lead Acid Batteries</li>
<li>Alkaline Batteries</li>
<li>Cardboard</li>
<li>Propane Tanks &#8211; fee applies</li>
<li>Porcelain Toilets &amp; Sinks &#8211; fee applies</li>
<li>Appliances &amp; Scrap Metal &#8211; some fees apply</li>
<li>Refrigerators &amp; Freezers &#8211; fee applies</li>
<li>Bulky wood</li>
<li>Mattresses/Box Springs &#8211; fee applies</li>
</ul>
</li>
</ul>
<p>**Be safe &#8211; wear masks, gloves, and pack your items so they can be removed quickly.**</p>
<p>Please refer to King County Public Health’s COVID-19 page at <a href="http://kingcounty.gov/covid" target="_blank" rel="noopener noreferrer"><strong>kingcounty.gov/covid</strong></a> for information about guidelines and recommendations.</p>
<p>For event information call Des Moines City Hall 206-870-7576. Alternative formats or disability accommodations on request 206-870-7576. TTY Relay: 711.</p>
<p>Des Moines Marina is located at 22307 Dock Street:</p>
<p><center><iframe loading="lazy" src="about:blank" width="600" height="450" frameborder="0" style="border:0;" allowfullscreen="" aria-hidden="false" tabindex="0" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d2862.2890927254193!2d-122.331405348699!3d47.40144427906934!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x54905afe7452bb3d%3A0x347def5504cb0a07!2s22307%20Dock%20Ave%20S%2C%20Des%20Moines%2C%20WA%2098198!5e1!3m2!1sen!2sus!4v1602353136365!5m2!1sen!2sus"></iframe><noscript><iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d2862.2890927254193!2d-122.331405348699!3d47.40144427906934!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x54905afe7452bb3d%3A0x347def5504cb0a07!2s22307%20Dock%20Ave%20S%2C%20Des%20Moines%2C%20WA%2098198!5e1!3m2!1sen!2sus!4v1602353136365!5m2!1sen!2sus" width="600" height="450" frameborder="0" style="border:0;" allowfullscreen="" aria-hidden="false" tabindex="0"></iframe></noscript></center></p>
<div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_1555553828'><broadstreet-zone callback="zone_load_1555553828" zone-id="76232" keywords="not_home_page,not_landing_page,is_article_page,des-moines,environment,events,featured-post,news,fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/&#038;t=Fall%20Recycling%20Collection%20Event%20will%20be%20at%20Des%20Moines%20Marina%20on%20Saturday%2C%20Oct.%2031" class="social-share-link" title="Share &quot;Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31&quot; via Facebook" data-network-name="facebook" data-share-title="Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31" data-share-url="http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=Fall%20Recycling%20Collection%20Event%20will%20be%20at%20Des%20Moines%20Marina%20on%20Saturday%2C%20Oct.%2031%20http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/" class="social-share-link" title="Share &quot;Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31&quot; via Twitter" data-network-name="twitter" data-share-title="Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31" data-share-url="http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://plus.google.com/share?url=http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/&#038;t=Fall%20Recycling%20Collection%20Event%20will%20be%20at%20Des%20Moines%20Marina%20on%20Saturday%2C%20Oct.%2031" class="social-share-link" title="Share &quot;Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31&quot; via Google +" data-network-name="googleplus" data-share-title="Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31" data-share-url="http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/">
<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover"></span>
</a><a href="https://www.pinterest.com/pin/create/button/?url=http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/&#038;description=Fall%20Recycling%20Collection%20Event%20will%20be%20at%20Des%20Moines%20Marina%20on%20Saturday%2C%20Oct.%2031&#038;media=http://waterlandblog.com/wp-content/uploads/2020/10/WLB-DMRecyclingEvent103120-150x150.jpg" class="social-share-link" title="Share &quot;Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31&quot; via Pinterest" data-network-name="pinterest" data-share-title="Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31" data-share-url="http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/">
<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/&#038;title=Fall%20Recycling%20Collection%20Event%20will%20be%20at%20Des%20Moines%20Marina%20on%20Saturday%2C%20Oct.%2031" class="social-share-link" title="Share &quot;Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31" data-share-url="http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31&quot; via Email" data-network-name="basic_email" data-share-title="Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31" data-share-url="http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31&quot; via Print" data-network-name="basic_print" data-share-title="Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31" data-share-url="http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #336666;
									}
								</style>
</div>
<div class="et_pb_extra_row etad post_below">
<div class="adsense-responsive-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-2062216921302425" data-ad-slot="8599006172"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div> </div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="http://waterlandblog.com/2020/10/09/highline-public-schools-will-remain-in-full-distance-learning-for-first-semester/" rel="prev"><span class="button">Previous</span><span class="title">Highline Public Schools will remain in full Distance Learning for first semester</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
 
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center>
 
<div class="bib--rcm-init" data-recommendation-key="afc6717d-e28c-49b3-b9a9-2f13e17a38e4" data-style-classes="bib--row-3 bib--hover bib--recency-show">
</div>
 

<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style><div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=9fe925a76f" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Get Des Moines WA news delivered FREE at 6pm daily via email:</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_9fe925a76f" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>


<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://waterlandblog.com/wp-comments-post.php?wpe-comment-post=waterlandblog" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='138180' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="332385befa" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="123" /></p></form> </div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="http://waterlandblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="bs_zones-13" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76243" keywords="not_home_page,not_landing_page,is_article_page,des-moines,environment,events,featured-post,news,fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-15" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76244" keywords="not_home_page,not_landing_page,is_article_page,des-moines,environment,events,featured-post,news,fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="72704" keywords="not_home_page,not_landing_page,is_article_page,des-moines,environment,events,featured-post,news,fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31,post" soft-keywords="true" zone-alias="Steadman"></broadstreet-zone></div></div> <div id="text-2" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT LOCAL JOURNALISM</h4> <div class="textwidget"><p><a href="https://waterlandblog.com/support-local-journalism/"><img loading="lazy" class="aligncenter size-full wp-image-137698" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20250'%3E%3C/svg%3E" alt="" width="300" height="250" data-lazy-src="http://waterlandblog.com/wp-content/uploads/2020/06/WLBSupportAd300x250-1.jpg" /><noscript><img loading="lazy" class="aligncenter size-full wp-image-137698" src="http://waterlandblog.com/wp-content/uploads/2020/06/WLBSupportAd300x250-1.jpg" alt="" width="300" height="250" /></noscript></a></p>
</div>
</div> <div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4></div> <div id="bs_zones-6" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76246" keywords="not_home_page,not_landing_page,is_article_page,des-moines,environment,events,featured-post,news,fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-14" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="72685" keywords="not_home_page,not_landing_page,is_article_page,des-moines,environment,events,featured-post,news,fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31,post" soft-keywords="true" zone-alias="prime3"></broadstreet-zone></div></div> <div id="tribe-events-list-widget-2" class="et_pb_widget tribe-events-list-widget"><h4 class="widgettitle">Upcoming Events</h4>
<ol class="tribe-list-widget">
<li class="tribe-events-list-widget-events type-tribe_events post-138175 tribe-clearfix tribe-events-venue-137530 tribe-events-organizer-137531">

<h4 class="tribe-event-title">
<a href="http://waterlandblog.com/event/south-king-county-candidates-forum-will-be-wednesday-oct-14/" rel="bookmark">South King County Candidates Forum will be Wednesday, Oct. 14</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">October 14 @ 6:00 pm</span> - <span class="tribe-event-time">8:00 pm</span> </div>
</li>
</ol>
<p class="tribe-events-widget-link">
<a href="http://waterlandblog.com/events/" rel="bookmark">View All Events</a>
</p>
</div> <script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"South King County Candidates Forum will be Wednesday, Oct. 14","description":"&lt;p&gt;If you live in Des Moines, Burien, Normandy Park, SeaTac, Tukwila, Kent, Renton, or South Seattle, you can Zoom in on a forum for legislative candidates for your district and ask questions on Wednesday, Oct. 14, 2020. This live online event will take place on Wednesday, Oct. 14, 2020, from 6 \u2013 8 p.m. All [&hellip;]&lt;/p&gt;\\n","url":"http://waterlandblog.com/event/south-king-county-candidates-forum-will-be-wednesday-oct-14/","startDate":"2020-10-14T18:00:00-07:00","endDate":"2020-10-14T20:00:00-07:00","location":{"@type":"Place","name":"Online","description":"","url":"","address":{"@type":"PostalAddress","addressLocality":"Des Moines","addressRegion":"WA","postalCode":"98198","addressCountry":"United States"},"telephone":"","sameAs":""},"organizer":{"@type":"Person","name":"Seattle Southside Chamber of Commerce","description":"","url":"","telephone":"","email":"","sameAs":""},"performer":"Organization"}]
</script><div id="bs_zones-10" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76235" keywords="not_home_page,not_landing_page,is_article_page,des-moines,environment,events,featured-post,news,fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> 
<div id="recent-posts-2" class="et_pb_widget widget_recent_entries">
<h4 class="widgettitle">Recent Posts</h4>
<ul>
<li>
<a href="http://waterlandblog.com/2020/10/10/fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31/" aria-current="page">Fall Recycling Collection Event will be at Des Moines Marina on Saturday, Oct. 31</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/10/09/highline-public-schools-will-remain-in-full-distance-learning-for-first-semester/">Highline Public Schools will remain in full Distance Learning for first semester</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/10/08/south-king-county-candidates-forum-will-be-wednesday-oct-14/">South King County Candidates Forum will be Wednesday, Oct. 14</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/10/06/photos-scenes-from-around-des-moines-in-the-fall/">PHOTOS: Scenes from around Des Moines in the fall</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/10/05/seattle-southside-chamber-announces-finalists-for-2020-business-awards-watch-party-is-nov-4/">Seattle Southside Chamber announces finalists for 2020 Business Awards; Watch Party is Nov. 4</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/10/01/nominations-announced-for-seattle-southside-chambers-2021-board-of-directors/">Nominations announced for Seattle Southside Chamber&#8217;s 2021 Board of Directors</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/09/30/bat-theatres-bauer-an-amazing-tale-of-art-and-life-opens-oct-10/">BAT Theatre&#8217;s &#8216;Bauer&#8217; – an amazing tale of art and life – opens Oct. 10</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/09/29/port-of-seattle-holding-community-sessions-on-2021-budget-and-capital-investment-program/">Port of Seattle holding community sessions on 2021 Budget and Capital Investment Program</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/09/29/dal-law-firm-do-i-need-a-community-property-agreement/">DAL Law Firm: Do I need a community property agreement?</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/09/28/midway-sewer-district-spillage-has-closed-saltwater-state-park-again/">Midway Sewer District spillage has closed Saltwater State Park again</a>
</li>
</ul>
</div> <div id="zoom-social-icons-widget-2" class="et_pb_widget zoom-social-icons-widget"><h4 class="widgettitle">Follow us</h4>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/waterlandblog" target="_blank">

<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 24px; padding:4px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/waterlandblog" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#55acee" style="background-color : #55acee; font-size: 24px; padding:4px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://www.youtube.com/channel/UCfavFUPHY9UUl2WdzwXi9cg" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-youtube" data-hover-rule="background-color" data-hover-color="#e02a20" style="background-color : #e02a20; font-size: 24px; padding:4px"></span>
<span class="zoom-social_icons-list__label">YouTube</span>
</a>
</li>
</ul>
</div> <div id="et_ads-3" class="et_pb_widget widget_et_ads"> <div class="widget_content clearfix">
<div class="etad">
<a href="http://desmoinesumc.org" target="_blank">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Des Moines United Methodist Church" data-lazy-src="https://waterlandblog.com/wp-content/uploads/2019/11/DMUMC300x250Ad-1.jpg" /><noscript><img src="https://waterlandblog.com/wp-content/uploads/2019/11/DMUMC300x250Ad-1.jpg" alt="Des Moines United Methodist Church" /></noscript>
</a>
</div>
</div>
</div> 
<div id="wpp-2" class="et_pb_widget popular-posts">
<h4 class="widgettitle">Popular Posts</h4>

<ul class="wpp-list">
<li>
<a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/" class="wpp-post-title" target="_self">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a>
<span class="wpp-meta post-stats"><span class="wpp-views">11.5k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/08/27/looks-like-the-historic-landmark-on-the-sound-has-been-sold/" class="wpp-post-title" target="_self">Looks like the historic Landmark on the Sound has been sold</a>
<span class="wpp-meta post-stats"><span class="wpp-views">7.6k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/02/15/two-teachers-forced-out-of-buriens-kennedy-catholic-high-school-due-to-lgbt-status/" class="wpp-post-title" target="_self">Two teachers forced out of Burien&#8217;s Kennedy Catholic High School due to LGBT status</a>
<span class="wpp-meta post-stats"><span class="wpp-views">4.7k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/10/27/suspect-wanted-in-connection-with-sexual-assault-found-dead-in-des-moines-creek/" class="wpp-post-title" target="_self">Suspect wanted in connection with sexual assault found dead in Des Moines Creek</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3.7k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/05/31/man-stabbed-killed-in-domestic-violence-homicide-in-des-moines-saturday-night/" class="wpp-post-title" target="_self">Man stabbed, killed in domestic violence homicide in Des Moines Saturday night</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3.2k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/07/18/fire-burns-restaurant-in-des-moines-friday-night/" class="wpp-post-title" target="_self">Fire burns abandoned restaurant in Des Moines Friday night</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.8k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/10/12/city-of-des-moines-announces-end-of-criminal-probe-into-actions-of-legacy-foundation/" class="wpp-post-title" target="_self">City of Des Moines announces end of criminal probe into actions of Legacy Foundation</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.7k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/08/04/des-moines-police-de-escalate-man-waving-loaded-gun-at-north-hill-espresso-stand/" class="wpp-post-title" target="_self">Des Moines Police de-escalate man waving loaded gun at North Hill Espresso stand</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.6k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/12/20/landslide-closes-woodmont-drive-s-at-marine-view-drive-s-friday/" class="wpp-post-title" target="_self">Landslide closes Woodmont Drive S. at Marine View Drive S. Friday</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.5k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/05/30/des-moines-police-chief-ken-thomas-issues-statement-on-police-killing-of-george-floyd/" class="wpp-post-title" target="_self">Des Moines Police Chief Ken Thomas issues statement on police killing of George Floyd</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.5k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/03/25/support-local-restaurants-during-the-quarantine-heres-a-take-out-directory/" class="wpp-post-title" target="_self">Support local restaurants during the quarantine – here&#8217;s a Take Out Directory</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.2k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/12/21/saltwater-state-park-closed-due-to-sewage-spill-discharge/" class="wpp-post-title" target="_self">Saltwater State Park closed due to sewage spill discharge</a>
<span class="wpp-meta post-stats"><span class="wpp-views">1.9k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/11/14/man-struck-killed-by-car-on-pacific-highway-s-early-thurs-morning/" class="wpp-post-title" target="_self">Man struck, killed by car on Pacific Highway S. early Thurs. morning</a>
<span class="wpp-meta post-stats"><span class="wpp-views">1.7k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/10/30/mt-rainier-high-put-into-lockdown-wednesday-due-to-report-of-gun-in-backpack/" class="wpp-post-title" target="_self">Mt. Rainier High put into lockdown Wednesday due to report of gun in backpack</a>
<span class="wpp-meta post-stats"><span class="wpp-views">1.7k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/10/09/update-arrests-made-in-murder-of-mt-rainier-high-student-juan-carlos-con-guzman/" class="wpp-post-title" target="_self">UPDATE: Arrests made in murder of Mt. Rainier High student Juan Carlos Con Guzman</a>
<span class="wpp-meta post-stats"><span class="wpp-views">1.7k views</span></span>
</li>
</ul>
</div> 
<div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Tim</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-24232">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Henry</span> on <a href="http://waterlandblog.com/2020/09/28/videos-deputy-mayor-other-electeds-discuss-policy-at-seattle-southside-chambers-mayors-reception/#comment-23573">VIDEOS: Deputy Mayor, other Electeds discuss policy at Seattle Southside Chamber&#8217;s Mayors Reception</a></li><li class="recentcomments"><span class="comment-author-link">Councilmember Anthony Martinelli</span> on <a href="http://waterlandblog.com/2020/09/25/city-of-des-moines-providing-435000-in-relief-grants-to-local-businesses/#comment-23307">City of Des Moines providing over half a million dollars in relief grants to local businesses</a></li><li class="recentcomments"><span class="comment-author-link">stand Fast</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-23172">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">PAmu</span> on <a href="http://waterlandblog.com/2020/09/22/motorcycle-crash-victim-thanks-des-moines-police-officers-who-saved-his-life/#comment-23155">Motorcycle crash victim thanks Des Moines Police Officers who saved his life</a></li><li class="recentcomments"><span class="comment-author-link">Stand Fast</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-23144">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Richard</span> on <a href="http://waterlandblog.com/2019/10/12/city-of-des-moines-announces-end-of-criminal-probe-into-actions-of-legacy-foundation/#comment-23075">City of Des Moines announces end of criminal probe into actions of Legacy Foundation</a></li><li class="recentcomments"><span class="comment-author-link">patnardo</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-23017">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Michael</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-20486">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Pat nardo</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-20444">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">PaTrick</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-20129">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">DD</span> on <a href="http://waterlandblog.com/2019/08/27/looks-like-the-historic-landmark-on-the-sound-has-been-sold/#comment-19474">Looks like the historic Landmark on the Sound has been sold</a></li><li class="recentcomments"><span class="comment-author-link">Zezak Gabelli</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-18990">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Ron Fowler</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-18895">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Joleene scott</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-18585">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Councilmember Anthony Martinelli</span> on <a href="http://waterlandblog.com/2020/08/04/des-moines-police-de-escalate-man-waving-loaded-gun-at-north-hill-espresso-stand/#comment-18421">Des Moines Police de-escalate man waving loaded gun at North Hill Espresso stand</a></li><li class="recentcomments"><span class="comment-author-link">Name *james hudson</span> on <a href="http://waterlandblog.com/2020/08/04/des-moines-police-de-escalate-man-waving-loaded-gun-at-north-hill-espresso-stand/#comment-18400">Des Moines Police de-escalate man waving loaded gun at North Hill Espresso stand</a></li></ul></div> <div id="bs_zones-12" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76241" keywords="not_home_page,not_landing_page,is_article_page,des-moines,environment,events,featured-post,news,fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> </div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_3">
<div class="container">
<div class="et_pb_extra_row container-width-change-notify">
<div class="et_pb_extra_column odd column-1">
<div id="rss-2" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget" href="http://b-townblog.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2014%2014'%3E%3C/svg%3E" alt="RSS" data-lazy-src="http://waterlandblog.com/wp-includes/images/rss.png" /><noscript><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://waterlandblog.com/wp-includes/images/rss.png" alt="RSS" /></noscript></a> <a class="rsswidget" href="https://b-townblog.com/">The B-Town (Burien) Blog</a></h4><ul><li><a class='rsswidget' href='https://b-townblog.com/2020/10/09/highline-public-schools-superintendent-susan-enfield/'>Highline Public Schools will remain in full Distance Learning for first semester</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/10/09/welcome-back-highline-heritage-museum-will-be-reopening-on-saturday-nov-7/'>Welcome back! Highline Heritage Museum will be reopening on Saturday, Nov. 7</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/10/09/low-income-k-12-students-in-highline-public-schools-getting-free-internet/'>Low-income K-12 students in Highline Public Schools getting free internet</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/10/09/burien-police-arrest-suspected-burglars-at-local-storage-facility/'>Burien Police arrest suspected burglars at local storage facility</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/10/08/fifth-graders-at-st-francis-school-holding-bake-sale-raffle-fundraiser-for-burien-cares-this-sunday-oct-11/'>Fifth graders at St. Francis School holding Bake Sale/Raffle fundraiser for Burien CARES this Sunday, Oct. 11</a></li></ul></div>  </div>
<div class="et_pb_extra_column even column-2">
<div id="rss-4" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget" href="http://ilovekent.net/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2014%2014'%3E%3C/svg%3E" alt="RSS" data-lazy-src="http://waterlandblog.com/wp-includes/images/rss.png" /><noscript><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://waterlandblog.com/wp-includes/images/rss.png" alt="RSS" /></noscript></a> <a class="rsswidget" href="https://www.ilovekent.net/">I Love Kent</a></h4><ul><li><a class='rsswidget' href='https://www.ilovekent.net/2020/10/08/man-killed-by-train-in-kent-thursday/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=man-killed-by-train-in-kent-thursday'>Man killed by train in Kent Thursday</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/10/08/kent-mayor-dana-ralph-issues-mayoral-directive-on-race-and-equity/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=kent-mayor-dana-ralph-issues-mayoral-directive-on-race-and-equity'>Kent Mayor Dana Ralph issues Mayoral Directive on race and equity</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/10/07/kent-city-council-adopts-sales-tax-ordinance-for-affordable-housing/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=kent-city-council-adopts-sales-tax-ordinance-for-affordable-housing'>Kent City Council adopts sales tax ordinance for Affordable Housing</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/10/06/free-flu-shots-for-kids-available-at-showare-center-drive-thru-clinic-oct-7-10/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=free-flu-shots-for-kids-available-at-showare-center-drive-thru-clinic-oct-7-10'>UPDATE: FREE vaccine clinic for kids at ShoWare Center moved to Sat., Oct. 17</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/10/05/video-mayor-ralph-delivers-proposed-2021-2022-biennial-budget-proposal-via-video/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=video-mayor-ralph-delivers-proposed-2021-2022-biennial-budget-proposal-via-video'>VIDEO: Mayor Ralph delivers proposed 2021-2022 Biennial Budget Proposal via video</a></li></ul></div>  </div>
<div class="et_pb_extra_column even column-4">
<div id="rss-3" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget" href="http://seatacblog.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2014%2014'%3E%3C/svg%3E" alt="RSS" data-lazy-src="http://waterlandblog.com/wp-includes/images/rss.png" /><noscript><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://waterlandblog.com/wp-includes/images/rss.png" alt="RSS" /></noscript></a> <a class="rsswidget" href="https://seatacblog.com/">The SeaTac Blog</a></h4><ul><li><a class='rsswidget' href='https://seatacblog.com/2020/10/09/highline-public-schools-will-remain-in-full-distance-learning-for-first-semester/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=highline-public-schools-will-remain-in-full-distance-learning-for-first-semester'>Highline Public Schools will remain in full Distance Learning for first semester</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/10/08/south-king-county-candidates-forum-will-be-wednesday-oct-14/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=south-king-county-candidates-forum-will-be-wednesday-oct-14'>South King County Candidates Forum will be Wednesday, Oct. 14</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/10/05/seatac-police-seeking-publics-help-identifying-car-prowlers/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=seatac-police-seeking-publics-help-identifying-car-prowlers'>SeaTac Police seeking public’s help identifying car prowlers</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/10/05/seattle-southside-chamber-announces-finalists-for-2020-business-awards-watch-party-is-nov-4/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=seattle-southside-chamber-announces-finalists-for-2020-business-awards-watch-party-is-nov-4'>Seattle Southside Chamber announces finalists for 2020 Business Awards; Watch Party is Nov. 4</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/10/03/how-you-can-support-truly-local-independent-journalism/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=how-you-can-support-truly-local-independent-journalism'>How you can support local, independent Journalism</a></li></ul></div>  </div>
</div>
</div>
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>

<div id="footer-nav">
<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/waterlandblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/waterlandblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
</li>
</ul>
</div> 
</div>
</div>
</footer>
</div> 
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','des-moines','environment','events','featured-post','news','fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["des-moines","environment","events","featured-post","news","fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31","post"],"url":"fall-recycling-collection-event-will-be-at-des-moines-marina-on-saturday-oct-31"};</script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/dist/i18n.min.js?ver=bb7c3c45d012206bfcd73d6a31f84d9e' id='wp-i18n-js'></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"http:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/images\/","ajaxurl":"http:\/\/waterlandblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"d4acc53852","timeline_nonce":"72a109fcca","blog_feed_nonce":"11eb27c5de","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"http:\/\/waterlandblog.com\/wp-admin\/admin-ajax.php","images_uri":"http:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/images","builder_images_uri":"http:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/includes\/builder\/images","et_frontend_nonce":"c6766343d9","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"ba34cb5795","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"138180","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script>window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;

            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;

                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );

                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };

                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="http://waterlandblog.com/wp-content/plugins/rocket-lazy-load/assets/js/16.1/lazyload.min.js"></script><script>"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><script src="http://waterlandblog.com/wp-content/cache/min/1/6e5e507c6b2333a4f220d0f5fd56e92c.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%7COpen%20Sans%3A300italic%2C400italic%2C600italic%2C700italic%2C800italic%2C400%2C300%2C600%2C700%2C800&#038;subset=latin%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="http://waterlandblog.com/wp-content/cache/min/1/a3e2107a8bf0229f95a86077c25366c8.css" media="all" data-minify="1" /></noscript></body>
</html>
