<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="http://waterlandblog.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="http://waterlandblog.com/wp-content/themes/Extra-2/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='http://waterlandblog.com';var et_post_id='138316';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Over 500 Nurses urge King County to confront recent COVID-19 surge | The Waterland Blog</title>

<link rel="canonical" href="http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/" />
<script type="text/javascript">
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-7386995-1', { 'cookieDomain': 'waterlandblog.com' } );
				// Plugins
				
				ga('send', 'pageview');
			</script>
<script async src="https://www.google-analytics.com/analytics.js"></script>

<link rel='dns-prefetch' href='//cdn.bibblio.org' />
<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Feed" href="http://waterlandblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Comments Feed" href="http://waterlandblog.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The Waterland Blog &raquo; iCal Feed" href="http://waterlandblog.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Over 500 Nurses urge King County to confront recent COVID-19 surge Comments Feed" href="http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/feed/" />

<script type="text/javascript" data-cfasync="false">
    (window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
	var mi_version         = '7.13.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-7386995-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-7386995-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/waterlandblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<meta content="Extra v.2.27.4" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tribe-common-skeleton-style-css' href='http://waterlandblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.12.12' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css' href='http://waterlandblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.12.12' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='http://waterlandblog.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-block-style-css' href='http://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/block/dist/blocks.style.build.css?ver=1602537697' type='text/css' media='all' />
<link rel='stylesheet' id='bibblio_related_posts-css' href='http://waterlandblog.com/wp-content/plugins/bibblio-related-posts/public/css/bibblio_related_posts-public.css?ver=1.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='bibblio-rcm-css-css' href='//cdn.bibblio.org/rcm/4.6/bib-related-content.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpb-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='weather-atlas-css' href='http://waterlandblog.com/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-css' href='http://waterlandblog.com/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css' href='http://waterlandblog.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='monsterinsights-popular-posts-style-css' href='http://waterlandblog.com/wp-content/plugins/google-analytics-for-wordpress/assets/css/frontend.min.css?ver=7.13.0' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='http://waterlandblog.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='extra-fonts-css' href="https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext" type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css' href='http://waterlandblog.com/wp-content/themes/Extra-2/style.css?ver=2.27.4' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-socicon-css' href='http://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/wpzoom-socicon.css?ver=1602537697' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-genericons-css' href='http://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/genericons.css?ver=1602537697' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-academicons-css' href='http://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/academicons.min.css?ver=1602537697' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-font-awesome-3-css' href='http://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/font-awesome-3.min.css?ver=1602537697' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='http://waterlandblog.com/wp-includes/css/dashicons.min.css?ver=5.5.3' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"http:\/\/waterlandblog.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://waterlandblog.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.13.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-content/plugins/bibblio-related-posts/public/js/bibblio_related_posts-public.js?ver=1.3.7' id='bibblio_related_posts-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.5.3' id='broadstreet-cdn-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1' id='weather-atlas-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1' id='jquery-cookie-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"http:\/\/waterlandblog.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":138316,"token":"25983c6a73","lang":0,"debug":0}
</script>
<script type='text/javascript' src='http://waterlandblog.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.4' id='wpp-js-js'></script>
<link rel="https://api.w.org/" href="http://waterlandblog.com/wp-json/" /><link rel="alternate" type="application/json" href="http://waterlandblog.com/wp-json/wp/v2/posts/138316" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://waterlandblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://waterlandblog.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Gov. Inslee issues Travel Advisory related to recent COVID-19 increases' href='http://waterlandblog.com/2020/11/13/gov-inslee-issues-travel-advisory-related-to-recent-covid-19-increases/' />
<link rel='shortlink' href='http://waterlandblog.com/?p=138316' />
<link rel="alternate" type="application/json+oembed" href="http://waterlandblog.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwaterlandblog.com%2F2020%2F11%2F15%2Fover-500-nurses-urge-king-county-to-confront-recent-covid-19-surge%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://waterlandblog.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwaterlandblog.com%2F2020%2F11%2F15%2Fover-500-nurses-urge-king-county-to-confront-recent-covid-19-surge%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://waterlandblog.com"><link rel="https://theeventscalendar.com/" href="http://waterlandblog.com/wp-json/tribe/events/v1/" /><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><script>
jQuery(function($){
	$('#footer-info').html('&copy; '+(new Date).getFullYear()+' <a href="https://www.southkingmedia.com/about/">South King Media</a>');
});
</script>
<script>
jQuery(function($){
    $('.et_pb_widget.widget_search .search-field').attr('placeholder', 'SEARCH THE WATERLAND BLOG...').css('opacity','1'); 
});
</script>
<script type="text/javascript">
	jQuery(document).ready(function($) {
		$(".et-social-icon a").attr('target', 'blank');
	});
</script>
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=A8A6TkKNx8g7fPvibXb7Gk87";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="http://waterlandblog.com/wp-content/cache/et/global/et-extra-customizer-global-160505472046.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-138316 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fullwidth_secondary_nav et_fixed_nav et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="et-trending">

<div id="et-trending">

<a id="et-trending-button" href="#" title="">
<span></span>
<span></span>
<span></span>
</a>

<h4 id="et-trending-label">
TRENDING: </h4>

<div id='et-trending-container'>
<div id="et-trending-post-57034" class="et-trending-post et-trending-latest">
<a href="http://waterlandblog.com/2015/11/13/mayor-lashes-out-at-new-seatac-councilmembers-for-lecturing-city/">Mayor lashes out at new SeaTac Councilmembers for lectu...</a>
</div>
<div id="et-trending-post-56236" class="et-trending-post">
<a href="http://waterlandblog.com/2015/09/11/council-tells-objectors-we-do-care-while-city-works-to-movemitigate-drug-clinic/">Council tells objectors ‘we do care’ while city works t...</a>
</div>
<div id="et-trending-post-50478" class="et-trending-post">
<a href="http://waterlandblog.com/2013/10/22/letter-reader-submits-political-cartoon-about-city-council-election/">LETTER: Reader submits political cartoon about City Cou...</a>
</div>
</div>
</div>
</div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/waterlandblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/waterlandblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
</ul>

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="http://waterlandblog.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="80">
<div class="container">


<a class="logo" href="http://waterlandblog.com/" data-fixed-height="51">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="The Waterland Blog" id="logo" data-lazy-src="https://waterlandblog.wpengine.com/wp-content/uploads/2019/09/WLBlogoSKM19-SMALLER.png" /><noscript><img src="https://waterlandblog.wpengine.com/wp-content/uploads/2019/09/WLBlogoSKM19-SMALLER.png" alt="The Waterland Blog" id="logo" /></noscript>
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-135956" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135956"><a href="https://waterlandblog.wpengine.com/">Home</a></li>
<li id="menu-item-137601" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-137601"><a href="http://waterlandblog.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-135957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-135957"><a href="http://waterlandblog.com/category/crime/">Crime</a></li>
<li id="menu-item-135958" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-135958"><a href="http://waterlandblog.com/category/business/">Business</a></li>
<li id="menu-item-135959" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135959"><a href="https://waterlandblog.wpengine.com/events/">Events</a></li>
<li id="menu-item-135981" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135981"><a href="http://waterlandblog.com/jobs/">Jobs</a></li>
<li id="menu-item-135980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135980"><a href="http://waterlandblog.com/weather/">Weather</a></li>
<li id="menu-item-136313" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136313"><a href="http://waterlandblog.com/coupons/">Coupons</a></li>
<li id="menu-item-136289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136289"><a href="http://waterlandblog.com/advertise/">Advertise</a></li>
<li id="menu-item-135984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-135984"><a href="http://waterlandblog.com/about/">About</a>
<ul class="sub-menu">
<li id="menu-item-136284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136284"><a href="http://waterlandblog.com/about/">About</a></li>
<li id="menu-item-135982" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135982"><a href="http://waterlandblog.com/how-to-submit-to-the-blog/">How to submit</a></li>
<li id="menu-item-135983" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135983"><a href="http://waterlandblog.com/contact/">Contact</a></li>
</ul>
</li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-138316" class="module single-post-module post-138316 post type-post status-publish format-standard has-post-thumbnail hentry category-business category-covid-19 category-des-moines category-featured-post category-health-wellness category-news tag-coronavirus tag-covid-19 tag-des-moines tag-health tag-news tag-nurses et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Over 500 Nurses urge King County to confront recent COVID-19 surge</h1>
<div class="post-meta vcard">
<p><span class="updated">Nov 15, 2020</span> | <a href="http://waterlandblog.com/category/business/" rel="tag">Business</a>, <a href="http://waterlandblog.com/category/covid-19/" rel="tag">COVID-19</a>, <a href="http://waterlandblog.com/category/des-moines/" rel="tag">Des Moines</a>, <a href="http://waterlandblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="http://waterlandblog.com/category/health-wellness/" rel="tag">Health &amp; Wellness</a>, <a href="http://waterlandblog.com/category/news/" rel="tag">News</a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Over 500 Nurses urge King County to confront recent COVID-19 surge" data-lazy-src="http://waterlandblog.com/wp-content/uploads/2020/11/SKM-MessageFromKingCountyNurses111520-1280x640.jpg" /><noscript><img src="http://waterlandblog.com/wp-content/uploads/2020/11/SKM-MessageFromKingCountyNurses111520-1280x640.jpg" alt="Over 500 Nurses urge King County to confront recent COVID-19 surge" /></noscript> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p><strong>Courtesy Public Health – Seattle &amp; King County&#8217;s <a href="https://publichealthinsider.com/2020/11/15/more-than-500-nurses-urge-king-county-to-confront-the-surge" target="_blank" rel="noopener noreferrer">Public Health Insider</a>:</strong></p>
<p style="padding-left: 40px;"><strong>In the midst of an unprecedented surge in COVID-19 cases, more than 500 King County nurses are issuing an urgent call to renew efforts to turn around this troubling trend.</strong></p>
<p style="padding-left: 40px;">“It’s been a tough year, and we’ve all sacrificed so much to stay safe. But now, with cases skyrocketing in King County, it’s more important than ever to stop the spread,” reads the nurses’ message, published Sunday in a special wrap-around section of The Seattle Times.</p>
<p style="padding-left: 40px;">Nurses have been on the front lines of the COVID-19 crisis since the pandemic’s beginning and they have seen firsthand what happens when our health care system is strained by a flood of COVID patients. With an appeal to act now, before our hospitals are overwhelmed, these 500 nurses urge King County residents:</p>
<p style="padding-left: 40px;">“Please, for us, for you and your families, and for our whole community, wear a mask whenever you’re in public, particularly indoors. Stay at least 6 feet from others outside your household. Avoid gatherings, especially inside, and reduce travel and other activities away from home. Get tested right away if you have COVID-19 symptoms or were in close contact with someone who is infected.”</p>
<p><a href="https://b-townblog.com/wp-content/uploads/2020/11/MessageFromKingCountyNurses111520.jpg"><img loading="lazy" class="aligncenter wp-image-149057 size-large" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20835%201024'%3E%3C/svg%3E" alt="" width="835" height="1024" data-lazy-src="https://b-townblog.com/wp-content/uploads/2020/11/MessageFromKingCountyNurses111520-835x1024.jpg" /><noscript><img loading="lazy" class="aligncenter wp-image-149057 size-large" src="https://b-townblog.com/wp-content/uploads/2020/11/MessageFromKingCountyNurses111520-835x1024.jpg" alt="" width="835" height="1024" /></noscript></a></p>
<p style="padding-left: 40px;">Free COVID tests are available at drive-through and walk-up sites all over King County. Check the back of the Seattle Times supplement for locations and hours or <strong><a href="https://www.kingcounty.gov/depts/health/covid-19/testing.aspx" target="_blank" rel="noopener noreferrer"><u>click here</u></a></strong> to find your closest testing site.</p>
<p style="padding-left: 40px;">We are at a precarious moment in the outbreak. King County’s case counts are more than twice as high as our previous peaks in April and July. This comes just as we are moving into the cold months and winter holidays, when we expect the virus to spread more readily. It is more important than ever to limit our travel, avoid gatherings and take extra precautions around our vulnerable friends, family and neighbors – especially those who are elderly or have underlying health conditions.</p>
<p style="padding-left: 40px;">“As a nurse, I am seeing my hospital start to fill up again with COVID-19 cases. While we’re not at a crisis point yet, we need to come together as a community – once again – to flatten the curve so that our hospitals aren’t overwhelmed. I am urging our entire community to do what we know from experience helps reduce COVID-19 transmission. Please wear a mask, maintain social distancing, wash your hands frequently, and avoid gatherings outside of your household. Nurses want to be here for you; we need you to be here for us and our community,” said Teresa Wren, RNC, BSN, Labor &amp; Delivery.</p>
<p style="padding-left: 40px;">Getting our outbreak under control can seem daunting. But as King County nurses remind us: “We’ve flattened the curve before, and we can do it again.”</p>
<p>&nbsp;</p>
<div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_1161332500'><broadstreet-zone callback="zone_load_1161332500" zone-id="76232" keywords="not_home_page,not_landing_page,is_article_page,business,covid-19,des-moines,featured-post,health-wellness,news,over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script>window.zone_load_1161332500 = function(z, d) { if (!d.count) document.getElementById('zone_load_1161332500').style.display = 'none'; };</script> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/&#038;t=Over%20500%20Nurses%20urge%20King%20County%20to%20confront%20recent%20COVID-19%20surge" class="social-share-link" title="Share &quot;Over 500 Nurses urge King County to confront recent COVID-19 surge&quot; via Facebook" data-network-name="facebook" data-share-title="Over 500 Nurses urge King County to confront recent COVID-19 surge" data-share-url="http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=Over%20500%20Nurses%20urge%20King%20County%20to%20confront%20recent%20COVID-19%20surge%20http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/" class="social-share-link" title="Share &quot;Over 500 Nurses urge King County to confront recent COVID-19 surge&quot; via Twitter" data-network-name="twitter" data-share-title="Over 500 Nurses urge King County to confront recent COVID-19 surge" data-share-url="http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://plus.google.com/share?url=http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/&#038;t=Over%20500%20Nurses%20urge%20King%20County%20to%20confront%20recent%20COVID-19%20surge" class="social-share-link" title="Share &quot;Over 500 Nurses urge King County to confront recent COVID-19 surge&quot; via Google +" data-network-name="googleplus" data-share-title="Over 500 Nurses urge King County to confront recent COVID-19 surge" data-share-url="http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/">
<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover"></span>
</a><a href="https://www.pinterest.com/pin/create/button/?url=http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/&#038;description=Over%20500%20Nurses%20urge%20King%20County%20to%20confront%20recent%20COVID-19%20surge&#038;media=http://waterlandblog.com/wp-content/uploads/2020/11/SKM-MessageFromKingCountyNurses111520-150x150.jpg" class="social-share-link" title="Share &quot;Over 500 Nurses urge King County to confront recent COVID-19 surge&quot; via Pinterest" data-network-name="pinterest" data-share-title="Over 500 Nurses urge King County to confront recent COVID-19 surge" data-share-url="http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/">
<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/&#038;title=Over%20500%20Nurses%20urge%20King%20County%20to%20confront%20recent%20COVID-19%20surge" class="social-share-link" title="Share &quot;Over 500 Nurses urge King County to confront recent COVID-19 surge&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Over 500 Nurses urge King County to confront recent COVID-19 surge" data-share-url="http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Over 500 Nurses urge King County to confront recent COVID-19 surge&quot; via Email" data-network-name="basic_email" data-share-title="Over 500 Nurses urge King County to confront recent COVID-19 surge" data-share-url="http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Over 500 Nurses urge King County to confront recent COVID-19 surge&quot; via Print" data-network-name="basic_print" data-share-title="Over 500 Nurses urge King County to confront recent COVID-19 surge" data-share-url="http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #336666;
									}
								</style>
</div>
<div class="et_pb_extra_row etad post_below">
<div class="adsense-responsive-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-2062216921302425" data-ad-slot="8599006172"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div> </div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="http://waterlandblog.com/2020/11/13/gov-inslee-issues-travel-advisory-related-to-recent-covid-19-increases/" rel="prev"><span class="button">Previous</span><span class="title">Gov. Inslee issues Travel Advisory related to recent COVID-19 increases</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
 
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center>
 
<div class="bib--rcm-init" data-recommendation-key="afc6717d-e28c-49b3-b9a9-2f13e17a38e4" data-style-classes="bib--row-3 bib--hover bib--recency-show">
</div>
 

<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"><style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style><div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=9fe925a76f" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Get Des Moines WA news delivered FREE at 6pm daily via email:</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_9fe925a76f" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>


<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://waterlandblog.com/wp-comments-post.php?wpe-comment-post=waterlandblog" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='138316' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c1acea360a" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="228" /></p></form> </div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="http://waterlandblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="bs_zones-13" class="et_pb_widget bs_zones"><h4 class="widgettitle">SUPPORT OUR SPONSORS</h4><div><broadstreet-zone zone-id="76243" keywords="not_home_page,not_landing_page,is_article_page,business,covid-19,des-moines,featured-post,health-wellness,news,over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-15" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76244" keywords="not_home_page,not_landing_page,is_article_page,business,covid-19,des-moines,featured-post,health-wellness,news,over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="72704" keywords="not_home_page,not_landing_page,is_article_page,business,covid-19,des-moines,featured-post,health-wellness,news,over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge,post" soft-keywords="true" zone-alias="Steadman"></broadstreet-zone></div></div> <div id="text-2" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT LOCAL JOURNALISM</h4> <div class="textwidget"><p><a href="https://waterlandblog.com/support-local-journalism/"><img loading="lazy" class="aligncenter size-full wp-image-137698" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20250'%3E%3C/svg%3E" alt="" width="300" height="250" data-lazy-src="http://waterlandblog.com/wp-content/uploads/2020/06/WLBSupportAd300x250-1.jpg" /><noscript><img loading="lazy" class="aligncenter size-full wp-image-137698" src="http://waterlandblog.com/wp-content/uploads/2020/06/WLBSupportAd300x250-1.jpg" alt="" width="300" height="250" /></noscript></a></p>
</div>
</div> <div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4><div class='weather-atlas-wrapper' style='background:#006699;border:1px solid #005588;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #005588'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Des Moines</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><script>/*<![CDATA[*/var weather_atlas_language = 'en';/*]]>*/</script><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-26'></i><span class='temp'>52°</span><div class='current_text'>Cloudy</div><div class='sunrise_sunset'>7:15am<i class='wi wi-fw wi-weather-32'></i>4:33pm PST</div></div><span class='current_text_2'>Feels like: 46<small>°F</small><br />Wind: 13<small>mph</small> SSW<br />Humidity: 78<small>%</small><br />Pressure: 30<small>"Hg</small><br />UV index: 1</span><div class='hourly hours' style='border-bottom:1px solid #005588'><span class='extended_hour extended_hour_1'>14<small>h</small></span><span class='extended_hour extended_hour_2'>15<small>h</small></span><span class='extended_hour extended_hour_3'>16<small>h</small></span></div><div class='hourly'><span class='extended_hour extended_hour_1' title='Cloudy'>52<small>°F</small><br /><i class='wi wi-fw wi-weather-26'></i></span><span class='extended_hour extended_hour_2' title='Cloudy'>52<small>°F</small><br /><i class='wi wi-fw wi-weather-26'></i></span><span class='extended_hour extended_hour_3' title='Few Showers'>52<small>°F</small><br /><i class='wi wi-fw wi-weather-11'></i></span></div><div class='daily days' style='border-bottom:1px solid #005588'><span class='extended_day extended_day_1'>Mon</span><span class='extended_day extended_day_2'>Tue</span><span class='extended_day extended_day_3'>Wed</span></div><div class='daily'><span class='extended_day extended_day_1' title='Rain'>50/50<small>°F</small><br /><i class='wi wi-fw wi-weather-12'></i></span><span class='extended_day extended_day_2' title='Rain / Wind'>57/46<small>°F</small><br /><i class='wi wi-fw wi-weather-12'></i></span><span class='extended_day extended_day_3' title='Rain / Thunder'>52/45<small>°F</small><br /><i class='wi wi-fw wi-weather-12'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #005588'><a href='https://www.weather-us.com/en/washington-usa/des-moines' title='Weather Atlas - Weather forecast Des Moines, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Des Moines, Washington &#9656;</span></a></div></div></div> <div id="bs_zones-6" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76246" keywords="not_home_page,not_landing_page,is_article_page,business,covid-19,des-moines,featured-post,health-wellness,news,over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-14" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="72685" keywords="not_home_page,not_landing_page,is_article_page,business,covid-19,des-moines,featured-post,health-wellness,news,over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge,post" soft-keywords="true" zone-alias="prime3"></broadstreet-zone></div></div> <div id="tribe-events-list-widget-2" class="et_pb_widget tribe-events-list-widget"><h4 class="widgettitle">Upcoming Events</h4>
<ol class="tribe-list-widget">
<li class="tribe-events-list-widget-events type-tribe_events post-138312 tribe-clearfix tribe-events-venue-137530 tribe-events-organizer-138313">

<h4 class="tribe-event-title">
<a href="http://waterlandblog.com/event/sr3-virtual-event-on-endangered-southern-resident-killer-whales-will-be-mon-nov-16/" rel="bookmark">SR3 virtual event on endangered southern resident Killer Whales will be Mon., Nov. 16</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">November 16 @ 9:30 am</span> - <span class="tribe-event-time">10:30 am</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-138311 tribe-clearfix tribe-events-venue-137900">

<h4 class="tribe-event-title">
<a href="http://waterlandblog.com/event/airport-jobs-next-health-insurance-enrollment-fair-will-be-thursday-nov-19/" rel="bookmark">Airport Jobs’ next Health Insurance Enrollment Fair will be Thursday, Nov. 19</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">November 19 @ 10:00 am</span> - <span class="tribe-event-time">4:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-138299 tribe-clearfix tribe-events-venue-137530 tribe-events-organizer-138300">

<h4 class="tribe-event-title">
<a href="http://waterlandblog.com/event/noel-cowards-witty-comedy-hay-fever-opens-virtually-at-bat-theatre-saturday-nov-21/" rel="bookmark">Noël Coward’s witty comedy &#8216;Hay Fever&#8217; opens virtually at BAT Theatre Saturday, Nov. 21</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">November 21 @ 8:00 pm</span> - <span class="tribe-event-time">9:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-138301 tribe-clearfix tribe-events-venue-137530 tribe-events-organizer-138300">

<h4 class="tribe-event-title">
<a href="http://waterlandblog.com/event/noel-cowards-witty-comedy-hay-fever-continues-virtually-at-bat-theatre-sunday-nov-22/" rel="bookmark">Noël Coward’s witty comedy &#8216;Hay Fever&#8217; continues virtually at BAT Theatre Sunday, Nov. 22</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">November 22 @ 2:00 pm</span> - <span class="tribe-event-time">3:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-138302 tribe-clearfix tribe-events-venue-137530 tribe-events-organizer-138300">

<h4 class="tribe-event-title">
<a href="http://waterlandblog.com/event/noel-cowards-witty-comedy-hay-fever-continues-virtually-at-bat-theatre-saturday-nov-28/" rel="bookmark">Noël Coward’s witty comedy &#8216;Hay Fever&#8217; continues virtually at BAT Theatre Saturday, Nov. 28</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">November 28 @ 8:00 pm</span> - <span class="tribe-event-time">9:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-138303 tribe-clearfix tribe-events-venue-137530 tribe-events-organizer-138300">

<h4 class="tribe-event-title">
<a href="http://waterlandblog.com/event/finale-for-bat-theatres-comedy-hay-fever-will-be-sunday-nov-29/" rel="bookmark">Finalé for BAT Theatre&#8217;s comedy &#8216;Hay Fever&#8217; will be Sunday, Nov. 29</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">November 29 @ 2:00 pm</span> - <span class="tribe-event-time">3:00 pm</span> </div>
</li>
</ol>
<p class="tribe-events-widget-link">
<a href="http://waterlandblog.com/events/" rel="bookmark">View All Events</a>
</p>
</div> <script type="application/ld+json">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</script><div id="bs_zones-10" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76235" keywords="not_home_page,not_landing_page,is_article_page,business,covid-19,des-moines,featured-post,health-wellness,news,over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> 
<div id="recent-posts-2" class="et_pb_widget widget_recent_entries">
<h4 class="widgettitle">Recent Posts</h4>
<ul>
<li>
<a href="http://waterlandblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/" aria-current="page">Over 500 Nurses urge King County to confront recent COVID-19 surge</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/11/13/gov-inslee-issues-travel-advisory-related-to-recent-covid-19-increases/">Gov. Inslee issues Travel Advisory related to recent COVID-19 increases</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/11/13/seattle-southside-chamber-updates-southside-promise-program-offers-1000-incentive-for-businesses/">Seattle Southside Chamber updates Southside Promise program, offers $1,000 incentive for businesses</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/11/13/ready-set-go-online-at-regions-biggest-art-party-starting-this-saturday-nov-14/">Ready, Set, Go online at region&#8217;s biggest art party starting this Saturday, Nov. 14</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/11/13/airport-jobs-next-health-insurance-enrollment-fair-will-be-thursday-nov-19/">Airport Jobs’ next Health Insurance Enrollment Fair will be Thursday, Nov. 19</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/11/12/noel-cowards-witty-comedy-hay-fever-continues-at-bat-theatre-starting-saturday-nov-21/">Noël Coward’s witty comedy &#8216;Hay Fever&#8217; opens virtually at BAT Theatre Saturday, Nov. 21</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/11/10/des-moines-sr3-virtual-event-on-endangered-southern-resident-killer-whales-will-be-mon-nov-16/">Des Moines&#8217; SR3 virtual event on endangered southern resident Killer Whales will be Mon., Nov. 16</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/11/10/the-3rd-annual-dinner-or-pardon-turkey-fundraiser-has-begun-in-normandy-park/">The 3rd annual &#8216;Dinner or Pardon&#8217; Turkey fundraiser has begun in Normandy Park</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/11/09/seattle-christian-school-holding-virtual-open-house-on-thursday-nov-17/">Seattle Christian School holding virtual Open House on Thursday, Nov. 17</a>
</li>
<li>
<a href="http://waterlandblog.com/2020/11/09/brad-tilden-retiring-as-ceo-of-alaska-airlines/">Brad Tilden retiring as CEO of Alaska Airlines</a>
</li>
</ul>
</div> <div id="zoom-social-icons-widget-2" class="et_pb_widget zoom-social-icons-widget"><h4 class="widgettitle">Follow us</h4>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/waterlandblog" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 24px; padding:4px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/waterlandblog" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#55acee" style="background-color : #55acee; font-size: 24px; padding:4px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://www.youtube.com/channel/UCfavFUPHY9UUl2WdzwXi9cg" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-youtube" data-hover-rule="background-color" data-hover-color="#e02a20" style="background-color : #e02a20; font-size: 24px; padding:4px"></span>
<span class="zoom-social_icons-list__label">YouTube</span>
</a>
</li>
</ul>
</div> <div id="et_ads-3" class="et_pb_widget widget_et_ads"> <div class="widget_content clearfix">
<div class="etad">
<a href="http://desmoinesumc.org" target="_blank">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Des Moines United Methodist Church" data-lazy-src="https://waterlandblog.com/wp-content/uploads/2019/11/DMUMC300x250Ad-1.jpg" /><noscript><img src="https://waterlandblog.com/wp-content/uploads/2019/11/DMUMC300x250Ad-1.jpg" alt="Des Moines United Methodist Church" /></noscript>
</a>
</div>
</div>
</div> 
<div id="wpp-2" class="et_pb_widget popular-posts">
<h4 class="widgettitle">Popular Posts</h4>

<ul class="wpp-list">
<li>
<a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/" class="wpp-post-title" target="_self">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a>
<span class="wpp-meta post-stats"><span class="wpp-views">12.3k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/08/27/looks-like-the-historic-landmark-on-the-sound-has-been-sold/" class="wpp-post-title" target="_self">Looks like the historic Landmark on the Sound has been sold</a>
<span class="wpp-meta post-stats"><span class="wpp-views">8.3k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/02/15/two-teachers-forced-out-of-buriens-kennedy-catholic-high-school-due-to-lgbt-status/" class="wpp-post-title" target="_self">Two teachers forced out of Burien&#8217;s Kennedy Catholic High School due to LGBT status</a>
<span class="wpp-meta post-stats"><span class="wpp-views">4.8k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/10/27/suspect-wanted-in-connection-with-sexual-assault-found-dead-in-des-moines-creek/" class="wpp-post-title" target="_self">Suspect wanted in connection with sexual assault found dead in Des Moines Creek</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3.8k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/05/31/man-stabbed-killed-in-domestic-violence-homicide-in-des-moines-saturday-night/" class="wpp-post-title" target="_self">Man stabbed, killed in domestic violence homicide in Des Moines Saturday night</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3.3k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/07/18/fire-burns-restaurant-in-des-moines-friday-night/" class="wpp-post-title" target="_self">Fire burns abandoned restaurant in Des Moines Friday night</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/10/12/city-of-des-moines-announces-end-of-criminal-probe-into-actions-of-legacy-foundation/" class="wpp-post-title" target="_self">City of Des Moines announces end of criminal probe into actions of Legacy Foundation</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.8k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/08/04/des-moines-police-de-escalate-man-waving-loaded-gun-at-north-hill-espresso-stand/" class="wpp-post-title" target="_self">Des Moines Police de-escalate man waving loaded gun at North Hill Espresso stand</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.6k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/12/20/landslide-closes-woodmont-drive-s-at-marine-view-drive-s-friday/" class="wpp-post-title" target="_self">Landslide closes Woodmont Drive S. at Marine View Drive S. Friday</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.5k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/05/30/des-moines-police-chief-ken-thomas-issues-statement-on-police-killing-of-george-floyd/" class="wpp-post-title" target="_self">Des Moines Police Chief Ken Thomas issues statement on police killing of George Floyd</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.5k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2020/03/25/support-local-restaurants-during-the-quarantine-heres-a-take-out-directory/" class="wpp-post-title" target="_self">Support local restaurants during the quarantine – here&#8217;s a Take Out Directory</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2.3k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/12/21/saltwater-state-park-closed-due-to-sewage-spill-discharge/" class="wpp-post-title" target="_self">Saltwater State Park closed due to sewage spill discharge</a>
<span class="wpp-meta post-stats"><span class="wpp-views">2k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/10/30/mt-rainier-high-put-into-lockdown-wednesday-due-to-report-of-gun-in-backpack/" class="wpp-post-title" target="_self">Mt. Rainier High put into lockdown Wednesday due to report of gun in backpack</a>
<span class="wpp-meta post-stats"><span class="wpp-views">1.8k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/11/14/man-struck-killed-by-car-on-pacific-highway-s-early-thurs-morning/" class="wpp-post-title" target="_self">Man struck, killed by car on Pacific Highway S. early Thurs. morning</a>
<span class="wpp-meta post-stats"><span class="wpp-views">1.8k views</span></span>
</li>
<li>
<a href="http://waterlandblog.com/2019/10/09/update-arrests-made-in-murder-of-mt-rainier-high-student-juan-carlos-con-guzman/" class="wpp-post-title" target="_self">UPDATE: Arrests made in murder of Mt. Rainier High student Juan Carlos Con Guzman</a>
<span class="wpp-meta post-stats"><span class="wpp-views">1.7k views</span></span>
</li>
</ul>
</div> 
<div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Bill</span> on <a href="http://waterlandblog.com/2019/08/27/looks-like-the-historic-landmark-on-the-sound-has-been-sold/#comment-25302">Looks like the historic Landmark on the Sound has been sold</a></li><li class="recentcomments"><span class="comment-author-link">STEPHANIE HW</span> on <a href="http://waterlandblog.com/2020/10/26/now-available-in-des-moines-ridwell-makes-it-easy-to-waste-less/#comment-25153">Now Available in Des Moines, Ridwell makes it easy to waste less</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://adamalsobrook.net' rel='external nofollow ugc' class='url'>Adam Alsobrook</a></span> on <a href="http://waterlandblog.com/2019/08/27/looks-like-the-historic-landmark-on-the-sound-has-been-sold/#comment-25001">Looks like the historic Landmark on the Sound has been sold</a></li><li class="recentcomments"><span class="comment-author-link">Cp</span> on <a href="http://waterlandblog.com/2019/08/27/looks-like-the-historic-landmark-on-the-sound-has-been-sold/#comment-24958">Looks like the historic Landmark on the Sound has been sold</a></li><li class="recentcomments"><span class="comment-author-link">Councilmember Anthony Martinelli</span> on <a href="http://waterlandblog.com/2020/10/16/city-of-des-moines-distributes-over-500000-to-grant-relief-opportunity-recipients/#comment-24673">City of Des Moines distributes over $500,000 to Grant Relief Opportunity recipients</a></li><li class="recentcomments"><span class="comment-author-link">Pati M</span> on <a href="http://waterlandblog.com/2020/10/16/city-of-des-moines-distributes-over-500000-to-grant-relief-opportunity-recipients/#comment-24665">City of Des Moines distributes over $500,000 to Grant Relief Opportunity recipients</a></li><li class="recentcomments"><span class="comment-author-link">Tim</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-24232">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Henry</span> on <a href="http://waterlandblog.com/2020/09/28/videos-deputy-mayor-other-electeds-discuss-policy-at-seattle-southside-chambers-mayors-reception/#comment-23573">VIDEOS: Deputy Mayor, other Electeds discuss policy at Seattle Southside Chamber&#8217;s Mayors Reception</a></li><li class="recentcomments"><span class="comment-author-link">Councilmember Anthony Martinelli</span> on <a href="http://waterlandblog.com/2020/09/25/city-of-des-moines-providing-435000-in-relief-grants-to-local-businesses/#comment-23307">City of Des Moines providing over half a million dollars in relief grants to local businesses</a></li><li class="recentcomments"><span class="comment-author-link">stand Fast</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-23172">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">PAmu</span> on <a href="http://waterlandblog.com/2020/09/22/motorcycle-crash-victim-thanks-des-moines-police-officers-who-saved-his-life/#comment-23155">Motorcycle crash victim thanks Des Moines Police Officers who saved his life</a></li><li class="recentcomments"><span class="comment-author-link">Stand Fast</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-23144">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Richard</span> on <a href="http://waterlandblog.com/2019/10/12/city-of-des-moines-announces-end-of-criminal-probe-into-actions-of-legacy-foundation/#comment-23075">City of Des Moines announces end of criminal probe into actions of Legacy Foundation</a></li><li class="recentcomments"><span class="comment-author-link">patnardo</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-23017">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Michael</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-20486">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">Pat nardo</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-20444">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li><li class="recentcomments"><span class="comment-author-link">PaTrick</span> on <a href="http://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/#comment-20129">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a></li></ul></div> <div id="bs_zones-12" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76241" keywords="not_home_page,not_landing_page,is_article_page,business,covid-19,des-moines,featured-post,health-wellness,news,over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> </div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_3">
<div class="container">
<div class="et_pb_extra_row container-width-change-notify">
<div class="et_pb_extra_column odd column-1">
<div id="rss-2" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget" href="http://b-townblog.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2014%2014'%3E%3C/svg%3E" alt="RSS" data-lazy-src="http://waterlandblog.com/wp-includes/images/rss.png" /><noscript><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://waterlandblog.com/wp-includes/images/rss.png" alt="RSS" /></noscript></a> <a class="rsswidget" href="https://b-townblog.com/">The B-Town (Burien) Blog</a></h4><ul><li><a class='rsswidget' href='https://b-townblog.com/2020/11/15/gov-inslee-announces-new-restrictions-relating-to-covid-19-pandemic-surge/'>Gov. Inslee announces new restrictions relating to COVID-19 pandemic surge</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/11/15/over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge/'>Over 500 Nurses urge King County to confront recent COVID-19 surge</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/11/14/downtown-burien-cookie-crawl-will-be/'>Discover Burien’s Downtown Cookie Crawl will be over 3 days starting Sat., Nov. 28</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/11/13/burien-teens-can-learn-video-audio-production-songwriting-in-new-online-course/'>Burien teens can learn video, audio production &amp; songwriting in new online course</a></li><li><a class='rsswidget' href='https://b-townblog.com/2020/11/13/burien-leaders-urge-community-to-take-precautions-against-covid-19/'>Burien leaders urge community to take precautions against COVID-19</a></li></ul></div>  </div>
<div class="et_pb_extra_column even column-2">
<div id="rss-4" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget" href="http://ilovekent.net/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2014%2014'%3E%3C/svg%3E" alt="RSS" data-lazy-src="http://waterlandblog.com/wp-includes/images/rss.png" /><noscript><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://waterlandblog.com/wp-includes/images/rss.png" alt="RSS" /></noscript></a> <a class="rsswidget" href="https://www.ilovekent.net/">I Love Kent</a></h4><ul><li><a class='rsswidget' href='https://www.ilovekent.net/2020/11/13/gov-inslee-issues-travel-advisory-related-to-recent-covid-19-increases/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=gov-inslee-issues-travel-advisory-related-to-recent-covid-19-increases'>Gov. Inslee issues Travel Advisory related to recent COVID-19 increases</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/11/13/are-you-ready-for-winter-city-of-kent-says-it-is-and-has-a-video-to-prove-it/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=are-you-ready-for-winter-city-of-kent-says-it-is-and-has-a-video-to-prove-it'>Are YOU ready for winter? City of Kent says it is, and has a video to prove it</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/11/13/have-you-been-tested-yet-here-are-local-covid-19-testing-locations/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=have-you-been-tested-yet-here-are-local-covid-19-testing-locations'>Have you been tested yet? Here are local COVID-19 testing locations</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/11/13/community-thanksgiving-dinner-will-be-a-drive-thru-on-saturday-nov-21/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=community-thanksgiving-dinner-will-be-a-drive-thru-on-saturday-nov-21'>Community Thanksgiving Dinner will be a drive-thru on Saturday, Nov. 21</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2020/11/13/ready-set-go-online-at-regions-biggest-art-party-starting-this-saturday-nov-14/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=ready-set-go-online-at-regions-biggest-art-party-starting-this-saturday-nov-14'>Ready, Set, Go online at region’s biggest art party starting this Saturday, Nov. 14</a></li></ul></div>  </div>
<div class="et_pb_extra_column even column-4">
<div id="rss-3" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget" href="http://seatacblog.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2014%2014'%3E%3C/svg%3E" alt="RSS" data-lazy-src="http://waterlandblog.com/wp-includes/images/rss.png" /><noscript><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://waterlandblog.com/wp-includes/images/rss.png" alt="RSS" /></noscript></a> <a class="rsswidget" href="https://seatacblog.com/">The SeaTac Blog</a></h4><ul><li><a class='rsswidget' href='https://seatacblog.com/2020/11/13/seattle-southside-chamber-updates-southside-promise-program-offers-1000-incentive-for-businesses/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=seattle-southside-chamber-updates-southside-promise-program-offers-1000-incentive-for-businesses'>Seattle Southside Chamber updates Southside Promise program, offers $1,000 incentive for businesses</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/11/13/seatac-city-council-decides-not-to-increase-city-property-tax-levy/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=seatac-city-council-decides-not-to-increase-city-property-tax-levy'>SeaTac City Council decides not to increase city property tax levy</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/11/13/gov-inslee-issues-travel-advisory-recommends-14-day-quarantines-for-travelers/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=gov-inslee-issues-travel-advisory-recommends-14-day-quarantines-for-travelers'>Gov. Inslee issues Travel Advisory, recommends 14-day quarantines for travelers</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/11/13/ready-set-go-online-at-regions-biggest-art-party-starting-this-saturday-nov-14/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=ready-set-go-online-at-regions-biggest-art-party-starting-this-saturday-nov-14'>Ready, Set, Go online at region’s biggest art party starting this Saturday, Nov. 14</a></li><li><a class='rsswidget' href='https://seatacblog.com/2020/11/13/airport-jobss-next-health-insurance-enrollment-fair-will-be-thursday-nov-19/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=airport-jobss-next-health-insurance-enrollment-fair-will-be-thursday-nov-19'>Airport Jobs’ next Health Insurance Enrollment Fair will be Thursday, Nov. 19</a></li></ul></div>  </div>
</div>
</div>
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>

<div id="footer-nav">
<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/waterlandblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/waterlandblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
</li>
</ul>
</div> 
</div>
</div>
</footer>
</div> 
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','business','covid-19','des-moines','featured-post','health-wellness','news','over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["business","covid-19","des-moines","featured-post","health-wellness","news","over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge","post"],"url":"over-500-nurses-urge-king-county-to-confront-recent-covid-19-surge"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6233);
 });</script> <script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script type="text/javascript">
			</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><link rel='stylesheet' id='tribe-events-custom-jquery-styles-css' href='http://waterlandblog.com/wp-content/plugins/the-events-calendar/vendor/jquery/smoothness/jquery-ui-1.8.23.custom.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-bootstrap-datepicker-css-css' href='http://waterlandblog.com/wp-content/plugins/the-events-calendar/vendor/bootstrap-datepicker/css/bootstrap-datepicker.standalone.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-style-css' href='http://waterlandblog.com/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme.min.css?ver=5.2.1' type='text/css' media='all' />
<script type='text/javascript' src='//cdn.bibblio.org/rcm/4.6/bib-related-content.js?ver=5.5.3' id='bibblio-rcm-js-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-content/plugins/simple-posts-ticker/public/js/jquery.marquee.min.js?ver=1.5.0' id='spt-ticker-js-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-content/plugins/simple-posts-ticker/public/js/ticker.min.js?ver=1.1.5' id='spt-init-js-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4' id='jquery-ui-widget-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4' id='jquery-ui-position-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="http://waterlandblog.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="http://waterlandblog.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="http://waterlandblog.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="http://waterlandblog.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="http://waterlandblog.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="http://waterlandblog.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/dist/dom-ready.min.js?ver=db63eb2f693cb5e38b083946b14f0684' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/dist/i18n.min.js?ver=bb7c3c45d012206bfcd73d6a31f84d9e' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/dist/a11y.min.js?ver=13971b965470c74a60fa32d392c78f2f' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"http:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/images\/","ajaxurl":"http:\/\/waterlandblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"9b3b849dcf","timeline_nonce":"15483452e2","blog_feed_nonce":"bc5c20325d","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"http:\/\/waterlandblog.com\/wp-admin\/admin-ajax.php","images_uri":"http:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/images","builder_images_uri":"http:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/includes\/builder\/images","et_frontend_nonce":"ef053caa69","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"d32dea3fce","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"138316","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='http://waterlandblog.com/wp-content/themes/Extra-2/scripts/scripts.min.js?ver=2.27.4' id='extra-scripts-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/comment-reply.min.js?ver=5.5.3' id='comment-reply-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1602537697' id='zoom-social-icons-widget-frontend-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-content/themes/Extra-2/core/admin/js/common.js?ver=3.27.4' id='et-core-common-js'></script>
<script type='text/javascript' src='http://waterlandblog.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='http://waterlandblog.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.7' id='akismet-form-js'></script>
<script>window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;

            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;

                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );

                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };

                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="http://waterlandblog.com/wp-content/plugins/rocket-lazy-load/assets/js/16.1/lazyload.min.js"></script></body>
</html>
