<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" dir="ltr" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if IE 7]>
<html id="ie7" dir="ltr" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if IE 8]>
<html id="ie8" dir="ltr" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html dir="ltr" lang="en-US" prefix="og: https://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://waterlandblog.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://waterlandblog.com/wp-content/themes/Extra-2/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://waterlandblog.com';var et_post_id='140908';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Burien UFO Block Party &amp; Metaphysical Fair will land at Town Square Park Sat., May 14 | The Waterland Blog</title>

<meta name="robots" content="max-image-preview:large" />
<link rel="canonical" href="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/" />
<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="The Waterland Blog | Local News, Events Politics, Crime, COVID-19 News, Arts &amp; more for Des Moines, WA" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Burien UFO Block Party &amp; Metaphysical Fair will land at Town Square Park Sat., May 14 | The Waterland Blog" />
<meta property="og:url" content="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/" />
<meta property="article:published_time" content="2022-05-10T17:06:02+00:00" />
<meta property="article:modified_time" content="2022-05-10T17:06:02+00:00" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Burien UFO Block Party &amp; Metaphysical Fair will land at Town Square Park Sat., May 14 | The Waterland Blog" />
<script type="text/javascript">
			window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
			ga('create', "UA-7386995-1", { 'cookieDomain': 'waterlandblog.com' } );
			ga('send', 'pageview');
		</script>
<script async src="https://www.google-analytics.com/analytics.js"></script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//clientcdn.pushengage.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Feed" href="https://waterlandblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Comments Feed" href="https://waterlandblog.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The Waterland Blog &raquo; iCal Feed" href="https://waterlandblog.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="The Waterland Blog &raquo; Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14 Comments Feed" href="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/feed/" />
<meta content="Extra v.2.27.4" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='gtranslate-style-css' href='https://waterlandblog.com/wp-content/plugins/gtranslate/gtranslate-style24.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://waterlandblog.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-block-style-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/block/dist/style-wpzoom-social-icons.css?ver=4.2.4' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link crossorigin="anonymous" rel='stylesheet' id='wpb-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='weather-atlas-css' href='https://waterlandblog.com/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-css' href='https://waterlandblog.com/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css' href='https://waterlandblog.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://waterlandblog.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.5.1' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='extra-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css' href='https://waterlandblog.com/wp-content/themes/Extra-2/style.css?ver=2.27.4' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-socicon-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/wpzoom-socicon.css?ver=1641922093' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-genericons-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/genericons.css?ver=1641922093' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-academicons-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/academicons.min.css?ver=1641922093' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-font-awesome-3-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/font-awesome-3.min.css?ver=1641922093' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://waterlandblog.com/wp-includes/css/dashicons.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-styles-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/wpzoom-social-icons-styles.css?ver=1641922093' type='text/css' media='all' />
<link rel='preload' as='font' id='wpzoom-social-icons-font-academicons-ttf-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.ttf?v=1.8.6' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-academicons-woff-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.woff?v=1.8.6' type='font/woff' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-fontawesome-3-ttf-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.ttf?v=4.7.0' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-fontawesome-3-woff-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff?v=4.7.0' type='font/woff' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-fontawesome-3-woff2-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff2?v=4.7.0' type='font/woff2' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-ttf-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-woff-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-socicon-ttf-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf?v=4.2.4' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-socicon-woff-css' href='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.woff?v=4.2.4' type='font/woff' crossorigin />
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player:focus-within{outline: 2px solid currentColor;outline-offset: 5px;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:100%;width:100%;left:0;top:0;position:absolute;background:url(https://waterlandblog.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat center;background-color: transparent !important;cursor:pointer;border:none;}
</style>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?v=1.43.8&#038;ver=5.9.3' id='broadstreet-cdn-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1' id='weather-atlas-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1' id='jquery-cookie-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/waterlandblog.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/waterlandblog.com\/wp-json\/wordpress-popular-posts","ID":140908,"token":"194ccfa91c","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://waterlandblog.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.5.1' id='wpp-js-js'></script>
<link rel="https://api.w.org/" href="https://waterlandblog.com/wp-json/" /><link rel="alternate" type="application/json" href="https://waterlandblog.com/wp-json/wp/v2/posts/140908" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://waterlandblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://waterlandblog.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://waterlandblog.com/?p=140908' />
<link rel="alternate" type="application/json+oembed" href="https://waterlandblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwaterlandblog.com%2F2022%2F05%2F10%2Fburien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://waterlandblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwaterlandblog.com%2F2022%2F05%2F10%2Fburien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14%2F&#038;format=xml" />
<style type="text/css">
		.feedzy-rss-link-icon:after {
			content: url( "https://waterlandblog.com/wp-content/plugins/feedzy-rss-feeds/img/external-link.png" );
			margin-left: 3px;
		}
	</style>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://waterlandblog.com"><link rel="alternate" href="https://waterlandblog.com/wp-json/tribe/events/v1/" /> <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="amphtml" href="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/amp/">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-7386995-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-7386995-1');
</script>
<script>
jQuery(function($){
	$('#footer-info').html('&copy; '+(new Date).getFullYear()+' <a href="https://www.southkingmedia.com/about/">South King Media</a>');
});
</script>
<script>
jQuery(function($){
    $('.et_pb_widget.widget_search .search-field').attr('placeholder', 'SEARCH THE WATERLAND BLOG...').css('opacity','1'); 
});
</script>
<script type="text/javascript">
	jQuery(document).ready(function($) {
		$(".et-social-icon a").attr('target', 'blank');
	});
</script>
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=A8A6TkKNx8g7fPvibXb7Gk87";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://waterlandblog.com/wp-content/cache/et/global/et-extra-customizer-global-165221300033.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script async src='/cdn-cgi/challenge-platform/h/b/scripts/invisible.js?ts=1652212800'></script></head>
<body class="post-template-default single single-post postid-140908 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fullwidth_secondary_nav et_fixed_nav et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="et-trending">

<div id="et-trending">

<a id="et-trending-button" href="#" title="">
<span></span>
<span></span>
<span></span>
</a>

<h4 id="et-trending-label">
TRENDING: </h4>

<div id='et-trending-container'>
<div id="et-trending-post-57034" class="et-trending-post et-trending-latest">
<a href="https://waterlandblog.com/2015/11/13/mayor-lashes-out-at-new-seatac-councilmembers-for-lecturing-city/">Mayor lashes out at new SeaTac Councilmembers for lectu...</a>
</div>
<div id="et-trending-post-56236" class="et-trending-post">
<a href="https://waterlandblog.com/2015/09/11/council-tells-objectors-we-do-care-while-city-works-to-movemitigate-drug-clinic/">Council tells objectors ‘we do care’ while city works t...</a>
</div>
<div id="et-trending-post-50478" class="et-trending-post">
<a href="https://waterlandblog.com/2013/10/22/letter-reader-submits-political-cartoon-about-city-council-election/">LETTER: Reader submits political cartoon about City Cou...</a>
</div>
</div>
</div>
</div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/waterlandblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/waterlandblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/waterlandblog/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
</ul>

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="https://waterlandblog.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="80">
<div class="container">


<a class="logo" href="https://waterlandblog.com/" data-fixed-height="51">
<img src="https://waterlandblog.wpengine.com/wp-content/uploads/2019/09/WLBlogoSKM19-SMALLER.png" alt="The Waterland Blog" id="logo" />
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-135956" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-135956"><a href="https://waterlandblog.com">Home</a></li>
<li id="menu-item-135959" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135959"><a href="https://waterlandblog.com/events/">Events</a></li>
<li id="menu-item-135957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-135957"><a href="https://waterlandblog.com/category/crime/">Crime</a></li>
<li id="menu-item-140028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140028"><a href="https://waterlandblog.com/category/politics/">Politics</a></li>
<li id="menu-item-135958" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-135958"><a href="https://waterlandblog.com/category/business/">Business</a></li>
<li id="menu-item-135981" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135981"><a href="https://waterlandblog.com/jobs/">Jobs</a></li>
<li id="menu-item-135980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135980"><a href="https://waterlandblog.com/weather/">Weather</a></li>
<li id="menu-item-136289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136289"><a href="https://waterlandblog.com/advertise/">Advertise</a></li>
<li id="menu-item-135984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-135984"><a href="https://waterlandblog.com/about/">About</a>
<ul class="sub-menu">
<li id="menu-item-136284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136284"><a href="https://waterlandblog.com/about/">About</a></li>
<li id="menu-item-135982" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135982"><a href="https://waterlandblog.com/how-to-submit-to-the-blog/">How to submit</a></li>
<li id="menu-item-135983" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135983"><a href="https://waterlandblog.com/contact/">Contact</a></li>
</ul>
</li>
<li id="menu-item-139418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-139418"><a href="https://burien.bhhsnwrealestate.com"><img src="https://b-townblog.com/wp-content/uploads/2022/02/BHHSMenuButton200-22d.png" align="top" alt="Berkshire Hathaway HomeServices Northwest Realty" width="170" height="81"></a></li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-140908" class="module single-post-module post-140908 post type-post status-publish format-standard has-post-thumbnail hentry category-arts category-burien category-business category-des-moines category-entertainment category-events category-featured-post category-history category-news tag-bufo tag-burien tag-burien-ufo-festival tag-des-moines tag-flying-saucers tag-news tag-the-maury-island-incident tag-ufos et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14</h1>
<div class="post-meta vcard">
<p><span class="updated">May 10, 2022</span> | <a href="https://waterlandblog.com/category/arts/" rel="tag">Arts</a>, <a href="https://waterlandblog.com/category/burien/" rel="tag">Burien</a>, <a href="https://waterlandblog.com/category/business/" rel="tag">Business</a>, <a href="https://waterlandblog.com/category/des-moines/" rel="tag">Des Moines</a>, <a href="https://waterlandblog.com/category/entertainment/" rel="tag">Entertainment</a>, <a href="https://waterlandblog.com/category/events/" rel="tag">Events</a>, <a href="https://waterlandblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="https://waterlandblog.com/category/history/" rel="tag">History</a>, <a href="https://waterlandblog.com/category/news/" rel="tag">News</a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://waterlandblog.com/wp-content/uploads/2022/05/SKM-BUFO2022-b-1280x640.jpg" alt="Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p><strong>Discover Burien&#8217;s UFO (BUFO) Block Party and Metaphysical Fair will land at Town Square Park this Saturday, May 14, 2022.</strong></p>
<p>Come celebrate all things “out of this world” at this free, great local event, which will be held from <strong>5 – 10 p.m. on May 14.</strong></p>
<p>Activities and scenes from past BUFOs include:</p>
<p><iframe title="Burien UFO Festival &amp; Burien Film Festival Flash Mob 2016" width="1080" height="608" src="https://www.youtube.com/embed/fS0OcE8GSTY?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p><iframe title="Ellen Tailor Preivews the Burien UFO Festival" width="1080" height="608" src="https://www.youtube.com/embed/lfIkHqJxa38?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<ul>
<li style="list-style-type: none;">
<ul>
<li><strong>SCREENING OF LOCALLY-PRODUCED &#8216;THE MAURY ISLAND INCIDENT&#8217; FILM</strong><br />
BUFO was first created by John White and Shelli Park as a way to commemorate the release of the locally-produced, award-winning, historic UFO short film &#8220;<a href="https://mauryislandincident.com" target="_blank" rel="noopener"><strong>The Maury Island Incident</strong></a>,&#8221; which shot some scenes at the Tin Room. The film was executive produced by White, written and produced by Steve Edmiston, directed and produced by Scott Schaefer, and produced by Laura Beth and Scott Peterson, along with Danny House (who has a cameo in the Tin Room scene).</li>
<li><strong>FIND BERNARD OF BURIEN IN OLDE BURIEN! </strong><br />
Visit the orange Discover Burien tent for Bernard&#8217;s location throughout Burien! Find him in the nearby shops and bring back your completed form to be entered to win a fun surprise. All ages may participate as this is just as fun for the adults as it is for the kids.</li>
<li><strong>COSTUME CONTEST!</strong><br />
Wear your costumes! It&#8217;s more fun that way! Okay, it&#8217;s not a requirement, but you might want to have a little fun on this silly shenanigan kind of night.</li>
<li><strong>METAPHYSICAL FAIR!</strong><br />
We&#8217;re getting all kinds of otherworldly with a new Metaphysical Fair happening right in the center of the universe &#8211; BUFO.</li>
</ul>
</li>
</ul>
<p><strong>VENDOR BOOTHS AVAILABLE</strong><br />
Vendor booths are available from $40.00. Space is a 10’ x 10.’ Vendors are required to bring their own tent, tables and chairs. Load in will take place 2 hours prior to the start of the event. Load in information will be emailed our approximately 5 days prior to the event. Organizers are looking mainly for Metaphysical Vendors. <a href="https://www.discoverburien.org/bufo-vendor/b7krno7fm1mjoxkszl09vdfedmlvjw" target="_blank" rel="noopener"><strong>Apply online here</strong></a>.</p>
<p><strong>VOLUNTEERS NEEDED</strong><br />
Want to help us make B.U.F.O. awesome? We are looking for people to roll up their sleeves and help plan and organize , please email Debra George at <a href="/cdn-cgi/l/email-protection#aecbcaeecac7ddcdc1d8cbdcccdbdcc7cbc080c1dcc9"><strong><span class="__cf_email__" data-cfemail="07626347636e7464687162756572756e626929687560">[email&#160;protected]</span></strong></a> and state why this committee interests you and how you think you can help with planning. In general, we will meet via zoom and most meetings will be early evenings or late afternoons.</p>
<p>More info here: <a href="https://www.discoverburien.org/event-calendar/2022-burien-ufo-festival" target="_blank" rel="noopener"><strong>https://www.discoverburien.org/event-calendar/2022-burien-ufo-festival</strong></a></p>
<p>Burien Town Square Park is located at 480 SW 152nd Street:</p>
<p><center><iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d2808.384294508929!2d-122.34245708446028!3d47.467431205574684!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x5490449ce68ea12d%3A0x1ffd6f92b60bec76!2sTown%20Square%20Park!5e1!3m2!1sen!2sus!4v1651093703858!5m2!1sen!2sus" width="600" height="450" style="border:0;" allowfullscreen="" loading="lazy" referrerpolicy="no-referrer-when-downgrade"></iframe></center></p>
<div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_1101473396'><broadstreet-zone callback="zone_load_1101473396" zone-id="76232" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>window.zone_load_1101473396 = function(z, d) { if (!d.count) document.getElementById('zone_load_1101473396').style.display = 'none'; };</script> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/&#038;t=Burien%20UFO%20Block%20Party%20%26%20Metaphysical%20Fair%20will%20land%20at%20Town%20Square%20Park%20Sat.%2C%20May%2014" class="social-share-link" title="Share &quot;Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14&quot; via Facebook" data-network-name="facebook" data-share-title="Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14" data-share-url="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=Burien%20UFO%20Block%20Party%20%26%20Metaphysical%20Fair%20will%20land%20at%20Town%20Square%20Park%20Sat.%2C%20May%2014%20https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/" class="social-share-link" title="Share &quot;Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14&quot; via Twitter" data-network-name="twitter" data-share-title="Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14" data-share-url="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://www.pinterest.com/pin/create/button/?url=https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/&#038;description=Burien%20UFO%20Block%20Party%20%26%20Metaphysical%20Fair%20will%20land%20at%20Town%20Square%20Park%20Sat.%2C%20May%2014&#038;media=https://waterlandblog.com/wp-content/uploads/2022/05/SKM-BUFO2022-b-150x150.jpg" class="social-share-link" title="Share &quot;Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14&quot; via Pinterest" data-network-name="pinterest" data-share-title="Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14" data-share-url="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/">
<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/&#038;title=Burien%20UFO%20Block%20Party%20%26%20Metaphysical%20Fair%20will%20land%20at%20Town%20Square%20Park%20Sat.%2C%20May%2014" class="social-share-link" title="Share &quot;Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14" data-share-url="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14&quot; via Email" data-network-name="basic_email" data-share-title="Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14" data-share-url="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14&quot; via Print" data-network-name="basic_print" data-share-title="Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14" data-share-url="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #336666;
									}
								</style>
</div>
<div class="et_pb_extra_row etad post_below">
<div class="adsense-responsive-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-2062216921302425" data-ad-slot="8599006172"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div> </div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://waterlandblog.com/2022/05/09/highline-school-board-to-interview-applicants-for-district-5-director-wed-may-11/" rel="prev"><span class="button">Previous</span><span class="title">Highline School Board to interview applicants for District 5 Director Wed., May 11</span></a> </div>
<div class="nav-link nav-link-next">
<a href="https://waterlandblog.com/2022/05/10/applications-now-open-for-city-of-des-moines-small-business-assistance-program/" rel="next"><span class="button">Next</span><span class="title">Applications now open for City of Des Moines&#8217; Small Business Assistance Program</span></a> </div>
</div>
</nav>
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://waterlandblog.com/wp-comments-post.php?wpe-comment-post=waterlandblog" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='140908' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7f3dccf45b" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="113" /><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div id="gtranslate-2" class="et_pb_widget widget_gtranslate"><h4 class="widgettitle">Translate</h4>
<style>
.switcher {font-family:Arial;font-size:12pt;text-align:left;cursor:pointer;overflow:hidden;width:173px;line-height:17px;}
.switcher a {text-decoration:none;display:block;font-size:12pt;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;}
.switcher a img {vertical-align:middle;display:inline;border:0;padding:0;margin:0;opacity:0.8;}
.switcher a:hover img {opacity:1;}
.switcher .selected {background:#fff linear-gradient(180deg, #efefef 0%, #fff 70%);position:relative;z-index:9999;}
.switcher .selected a {border:1px solid #ccc;color:#666;padding:3px 5px;width:161px;}
.switcher .selected a:after {height:24px;display:inline-block;position:absolute;right:10px;width:15px;background-position:50%;background-size:11px;background-image:url("data:image/svg+xml;utf8,<svg xmlns='http://www.w3.org/2000/svg' width='16' height='16' viewBox='0 0 285 285'><path d='M282 76.5l-14.2-14.3a9 9 0 0 0-13.1 0L142.5 174.4 30.3 62.2a9 9 0 0 0-13.2 0L3 76.5a9 9 0 0 0 0 13.1l133 133a9 9 0 0 0 13.1 0l133-133a9 9 0 0 0 0-13z' style='fill:%23666'/></svg>");background-repeat:no-repeat;content:""!important;transition:all .2s;}
.switcher .selected a.open:after {-webkit-transform: rotate(-180deg);transform:rotate(-180deg);}
.switcher .selected a:hover {background:#fff}
.switcher .option {position:relative;z-index:9998;border-left:1px solid #ccc;border-right:1px solid #ccc;border-bottom:1px solid #ccc;background-color:#eee;display:none;width:171px;max-height:198px;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;overflow-y:auto;overflow-x:hidden;}
.switcher .option a {color:#000;padding:3px 5px;}
.switcher .option a:hover {background:#fff;}
.switcher .option a.selected {background:#fff;}
#selected_lang_name {float: none;}
.l_name {float: none !important;margin: 0;}
.switcher .option::-webkit-scrollbar-track{-webkit-box-shadow:inset 0 0 3px rgba(0,0,0,0.3);border-radius:5px;background-color:#f5f5f5;}
.switcher .option::-webkit-scrollbar {width:5px;}
.switcher .option::-webkit-scrollbar-thumb {border-radius:5px;-webkit-box-shadow: inset 0 0 3px rgba(0,0,0,.3);background-color:#888;}
</style>
<div class="switcher notranslate">
<div class="selected">
<a href="#" onclick="return false;"><img src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /> English</a>
</div>
<div class="option">
<a href="#" onclick="doGTranslate('en|zh-CN');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Chinese (Simplified)" class="nturl"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/zh-CN.png" height="24" width="24" alt="zh-CN" /> Chinese (Simplified)</a><a href="#" onclick="doGTranslate('en|en');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="English" class="nturl selected"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /> English</a><a href="#" onclick="doGTranslate('en|it');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Italian" class="nturl"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/it.png" height="24" width="24" alt="it" /> Italian</a><a href="#" onclick="doGTranslate('en|es');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Spanish" class="nturl"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/es-mx.png" height="24" width="24" alt="es" /> Spanish</a><a href="#" onclick="doGTranslate('en|uk');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Ukrainian" class="nturl"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/uk.png" height="24" width="24" alt="uk" /> Ukrainian</a><a href="#" onclick="doGTranslate('en|vi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Vietnamese" class="nturl"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/vi.png" height="24" width="24" alt="vi" /> Vietnamese</a></div>
</div>
<script>
jQuery('.switcher .selected').click(function() {jQuery('.switcher .option a img').each(function() {if(!jQuery(this)[0].hasAttribute('src'))jQuery(this).attr('src', jQuery(this).attr('data-gt-lazy-src'))});if(!(jQuery('.switcher .option').is(':visible'))) {jQuery('.switcher .option').stop(true,true).delay(100).slideDown(500);jQuery('.switcher .selected a').toggleClass('open')}});
jQuery('.switcher .option').bind('mousewheel', function(e) {var options = jQuery('.switcher .option');if(options.is(':visible'))options.scrollTop(options.scrollTop() - e.originalEvent.wheelDelta/10);return false;});
jQuery('body').not('.switcher').click(function(e) {if(jQuery('.switcher .option').is(':visible') && e.target != jQuery('.switcher .option').get(0)) {jQuery('.switcher .option').stop(true,true).delay(100).slideUp(500);jQuery('.switcher .selected a').toggleClass('open')}});
</script>
<style>#goog-gt-tt{display:none!important;}.goog-te-banner-frame{display:none!important;}.goog-te-menu-value:hover{text-decoration:none!important;}.goog-text-highlight{background-color:transparent!important;box-shadow:none!important;}body{top:0!important;}#google_translate_element2{display:none!important;}</style>
<div id="google_translate_element2"></div>
<script>function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}if(!window.gt_translate_script){window.gt_translate_script=document.createElement('script');gt_translate_script.src='https://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2';document.body.appendChild(gt_translate_script);}</script>
<script>
function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;if(typeof ga=='function'){ga('send', 'event', 'GTranslate', lang, location.hostname+location.pathname+location.search);}var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(sel[i].className.indexOf('goog-te-combo')!=-1){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}
if(GTranslateGetCurrentLang() != null)jQuery(document).ready(function() {var lang_html = jQuery('div.switcher div.option').find('img[alt="'+GTranslateGetCurrentLang()+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));});
</script>
<script>jQuery(document).ready(function() {var allowed_languages = ["zh-CN","en","it","es","uk","vi"];var accept_language = navigator.language.toLowerCase() || navigator.userLanguage.toLowerCase();switch(accept_language) {case 'zh-cn': var preferred_language = 'zh-CN'; break;case 'zh': var preferred_language = 'zh-CN'; break;case 'zh-tw': var preferred_language = 'zh-TW'; break;case 'zh-hk': var preferred_language = 'zh-TW'; break;case 'he': var preferred_language = 'iw'; break;default: var preferred_language = accept_language.substr(0, 2); break;}if(preferred_language != 'en' && GTranslateGetCurrentLang() == null && document.cookie.match('gt_auto_switch') == null && allowed_languages.indexOf(preferred_language) >= 0){doGTranslate('en|'+preferred_language);document.cookie = 'gt_auto_switch=1; expires=Thu, 05 Dec 2030 08:08:08 UTC; path=/;';var lang_html = jQuery('div.switcher div.option').find('img[alt="'+preferred_language+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));}});</script></div> <div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="https://waterlandblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="bs_zones-13" class="et_pb_widget bs_zones"><h4 class="widgettitle">SUPPORT OUR SPONSORS</h4><div><broadstreet-zone zone-id="76243" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-22" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76662" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-15" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76244" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-24" class="et_pb_widget bs_zones"><div><broadstreet-zone place="" zone-id="76245" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="72704" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias="Steadman"></broadstreet-zone></div></div> <div class="tribe-compatibility-container">
<div class="tribe-common tribe-events tribe-events-view tribe-events-view--widget-events-list tribe-events-widget" data-js="tribe-events-view" data-view-rest-nonce="194ccfa91c" data-view-rest-url="https://waterlandblog.com/wp-json/tribe/views/v2/html" data-view-manage-url="1" data-view-breakpoint-pointer="be1c0501-d5f3-4a6f-b58f-55c00850b48a">
<div class="tribe-events-widget-events-list">
<script type="application/ld+json">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</script>
<script data-js="tribe-events-view-data" type="application/json">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</script>
<header class="tribe-events-widget-events-list__header">
<h2 class="tribe-events-widget-events-list__header-title tribe-common-h6 tribe-common-h--alt">
Upcoming Events </h2>
</header>
<div class="tribe-events-widget-events-list__events">
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-05-14">
<span class="tribe-events-widget-events-list__event-date-tag-month">
May </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
14 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-140864 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-05-14">
<span class="tribe-event-date-start">12:00 pm</span> - <span class="tribe-event-time">5:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://waterlandblog.com/event/colorful-holi-by-the-ocean-festival-will-be-at-saltwater-state-park-saturday-may-14/" title="Colorful &#8216;Holi By the Ocean&#8217; festival will be at Saltwater State Park Saturday, May 14" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Colorful &#8216;Holi By the Ocean&#8217; festival will be at Saltwater State Park Saturday, May 14	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-05-14">
<span class="tribe-events-widget-events-list__event-date-tag-month">
May </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
14 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-140871 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-05-14">
<span class="tribe-event-date-start">12:00 pm</span> - <span class="tribe-event-time">5:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://waterlandblog.com/event/waterland-wine-art-walk-will-be-saturday-may-14/" title="Waterland Wine &#038; Art Walk will be Saturday, May 14" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Waterland Wine &#038; Art Walk will be Saturday, May 14	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-05-14">
<span class="tribe-events-widget-events-list__event-date-tag-month">
May </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
14 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-140910 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-05-14">
<span class="tribe-event-date-start">5:00 pm</span> - <span class="tribe-event-time">10:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://waterlandblog.com/event/burien-ufo-block-party-metaphysical-fair-will-land-on-saturday-may-14/" title="Burien UFO Block Party &#038; Metaphysical Fair will land on Saturday, May 14" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Burien UFO Block Party &#038; Metaphysical Fair will land on Saturday, May 14	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-06-04">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Jun </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
4 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-140822 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-06-04">
<span class="tribe-event-date-start">5:30 pm</span> - <span class="tribe-event-time">9:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://waterlandblog.com/event/multi-service-centers-crab-feed-and-auction-will-be-saturday-june-4/" title="Multi-Service Center&#8217;s Crab Feed and Auction will be Saturday, June 4" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Multi-Service Center&#8217;s Crab Feed and Auction will be Saturday, June 4	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-06-22">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Jun </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
22 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-140773 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-06-22">
<span class="tribe-event-date-start">6:00 pm</span> - <span class="tribe-event-time">8:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://waterlandblog.com/event/6-22-party-at-the-quarterdeck-will-commemorate-1947-local-origins-of-men-in-black/" title="&#8216;6/22&#8217; Party at the Quarterdeck will commemorate 1947 local origins of Men in Black" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
&#8216;6/22&#8217; Party at the Quarterdeck will commemorate 1947 local origins of Men in Black	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
</div>
<div class="tribe-events-widget-events-list__view-more tribe-common-b1 tribe-common-b2--min-medium">
<a href="https://waterlandblog.com/events/" class="tribe-events-widget-events-list__view-more-link tribe-common-anchor-thin" title="View more events.">
View Calendar	</a>
</div>
</div>
</div>
</div>
<script class="tribe-events-breakpoints">
	( function () {
		var completed = false;

		function initBreakpoints() {
			if ( completed ) {
				// This was fired already and completed no need to attach to the event listener.
				document.removeEventListener( 'DOMContentLoaded', initBreakpoints );
				return;
			}

			if ( 'undefined' === typeof window.tribe ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events.views ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events.views.breakpoints ) {
				return;
			}

			if ( 'function' !== typeof (window.tribe.events.views.breakpoints.setup) ) {
				return;
			}

			var container = document.querySelectorAll( '[data-view-breakpoint-pointer="be1c0501-d5f3-4a6f-b58f-55c00850b48a"]' );
			if ( ! container ) {
				return;
			}

			window.tribe.events.views.breakpoints.setup( container );
			completed = true;
			// This was fired already and completed no need to attach to the event listener.
			document.removeEventListener( 'DOMContentLoaded', initBreakpoints );
		}

		// Try to init the breakpoints right away.
		initBreakpoints();
		document.addEventListener( 'DOMContentLoaded', initBreakpoints );
	})();
</script>
<div id="text-2" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT LOCAL JOURNALISM</h4> <div class="textwidget"><p><a href="https://waterlandblog.com/support-local-journalism/"><img class="aligncenter size-full wp-image-137698" src="https://waterlandblog.com/wp-content/uploads/2020/06/WLBSupportAd300x250-1.jpg" alt="" width="300" height="250" /></a></p>
</div>
</div> <div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4><div class='weather-atlas-wrapper' style='background:#006699;border:1px solid #005588;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #005588'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Des Moines</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><script>/*<![CDATA[*/var weather_atlas_language = 'en';/*]]>*/</script><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-28'></i><span class='temp'>54°</span><div class='current_text'>Mostly Cloudy</div><div class='sunrise_sunset'>5:38am<i class='wi wi-fw wi-weather-32'></i>8:32pm PDT</div></div><span class='current_text_2'>Feels like: 52<small>°F</small><br />Wind: 9<small>mph</small> SSW<br />Humidity: 53<small>%</small><br />Pressure: 30.19<small>"Hg</small><br />UV index: 5</span><div class='hourly hours' style='border-bottom:1px solid #005588'><span class='extended_hour extended_hour_1'>14<small>h</small></span><span class='extended_hour extended_hour_2'>15<small>h</small></span><span class='extended_hour extended_hour_3'>16<small>h</small></span></div><div class='hourly'><span class='extended_hour extended_hour_1' title='Mostly Cloudy'>55<small>°F</small><br /><i class='wi wi-fw wi-weather-28'></i></span><span class='extended_hour extended_hour_2' title='Partly Cloudy'>57<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span><span class='extended_hour extended_hour_3' title='Partly Cloudy'>57<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span></div><div class='daily days' style='border-bottom:1px solid #005588'><span class='extended_day extended_day_1'>Wed</span><span class='extended_day extended_day_2'>Thu</span><span class='extended_day extended_day_3'>Fri</span></div><div class='daily'><span class='extended_day extended_day_1' title='Mostly Cloudy'>59/46<small>°F</small><br /><i class='wi wi-fw wi-weather-28'></i></span><span class='extended_day extended_day_2' title='Rain'>50/41<small>°F</small><br /><i class='wi wi-fw wi-weather-12'></i></span><span class='extended_day extended_day_3' title='Mostly Cloudy'>57/46<small>°F</small><br /><i class='wi wi-fw wi-weather-28'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #005588'><a href='https://www.weather-atlas.com/en/washington-usa/des-moines' title='Weather Atlas - Weather forecast Des Moines, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Des Moines, Washington &#9656;</span></a></div></div></div> <div id="bs_zones-23" class="et_pb_widget bs_zones"><div><broadstreet-zone place="5" zone-id="89639" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-6" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76246" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-10" class="et_pb_widget bs_zones"><div><broadstreet-zone place="" zone-id="76246" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">Get Local News via Email:</h4> <div class="textwidget"><p></p>
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif;  width:250px;}<br />
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.<br />
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */<br />
</style>
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=9fe925a76f" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<h2>Subscribe to our Daily 6pm Email Newsletter</h2>
<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br />
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<p></p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_2111f5e0753236f41d3b0f5ae_9fe925a76f" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form>
</div>
<p><script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script><br />
</p>
</div>
</div> <div id="bs_zones-25" class="et_pb_widget bs_zones"><div><broadstreet-zone place="" zone-id="76531" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> 
<div id="recent-posts-2" class="et_pb_widget widget_recent_entries">
<h4 class="widgettitle">Recent Posts</h4>
<ul>
<li>
<a href="https://waterlandblog.com/2022/05/10/dal-law-firm-ways-to-build-credit-after-bankruptcy/">DAL Law Firm: Ways to build credit after Bankruptcy</a>
</li>
<li>
<a href="https://waterlandblog.com/2022/05/10/applications-now-open-for-city-of-des-moines-small-business-assistance-program/">Applications now open for City of Des Moines&#8217; Small Business Assistance Program</a>
</li>
<li>
<a href="https://waterlandblog.com/2022/05/10/burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14/" aria-current="page">Burien UFO Block Party &#038; Metaphysical Fair will land at Town Square Park Sat., May 14</a>
</li>
<li>
<a href="https://waterlandblog.com/2022/05/09/highline-school-board-to-interview-applicants-for-district-5-director-wed-may-11/">Highline School Board to interview applicants for District 5 Director Wed., May 11</a>
</li>
<li>
<a href="https://waterlandblog.com/2022/05/09/help-stamp-out-hunger-by-leaving-food-donations-at-your-mailbox-on-sat-may-14/">Help &#8216;Stamp Out Hunger&#8217; by leaving food donations at your mailbox on Sat., May 14</a>
</li>
<li>
<a href="https://waterlandblog.com/2022/05/09/residents-invited-to-discuss-veterans-seniors-and-human-services-levy-may-24/">Residents invited to discuss Veterans, Seniors and Human Services Levy May 24</a>
</li>
<li>
<a href="https://waterlandblog.com/2022/05/09/call-for-artists-des-moines-memorial-drive-preservation-association-signal-box-project/">CALL FOR ARTISTS: Des Moines Memorial Drive Preservation Association Signal Box Project</a>
</li>
<li>
<a href="https://waterlandblog.com/2022/05/07/dubsea-fish-sticks-single-game-tickets-on-sale-now/">DubSea Fish Sticks single game tickets on sale now</a>
</li>
<li>
<a href="https://waterlandblog.com/2022/05/06/berkshire-hathaway-homeservices-northwest-real-estate-open-house-huntington-park-in-des-moines/">Berkshire Hathaway HomeServices Northwest Real Estate Open House: Huntington Park in Des Moines</a>
</li>
<li>
<a href="https://waterlandblog.com/2022/05/04/achievement-awards-will-be-awarded-at-june-22-celebration-of-original-men-in-black-encounterachievement-awards-featured-at-june-22-celebration-of-original-men-in-black-encounterachievement-awards/">Achievement Awards will be awarded at June 22 celebration of original Men in Black encounter</a>
</li>
</ul>
</div> <div id="zoom-social-icons-widget-2" class="et_pb_widget zoom-social-icons-widget"><h4 class="widgettitle">Follow us</h4>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/waterlandblog" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 24px; padding:4px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/waterlandblog" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#55acee" style="background-color : #55acee; font-size: 24px; padding:4px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://www.youtube.com/channel/UCfavFUPHY9UUl2WdzwXi9cg" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-youtube" data-hover-rule="background-color" data-hover-color="#e02a20" style="background-color : #e02a20; font-size: 24px; padding:4px"></span>
<span class="zoom-social_icons-list__label">YouTube</span>
</a>
</li>
</ul>
</div> <div id="et_ads-3" class="et_pb_widget widget_et_ads"> <div class="widget_content clearfix">
<div class="etad">
<a href="http://desmoinesumc.org" target="_blank">
<img src="https://waterlandblog.com/wp-content/uploads/2019/11/DMUMC300x250Ad-1.jpg" alt="Des Moines United Methodist Church" />
</a>
</div>
</div>
</div> 
<div id="wpp-2" class="et_pb_widget popular-posts">
<h4 class="widgettitle">Popular Posts</h4>
<ul class="wpp-list">
<li>
<a href="https://waterlandblog.com/2020/06/23/owner-of-wallys-says-not-easy-to-disavow-sons-involvement-with-proud-boys-extremist-group/" class="wpp-post-title" target="_self">Owner of Wally&#8217;s says ‘not easy’ to disavow son’s involvement with ‘Proud Boys’ extremist group</a>
<span class="wpp-meta post-stats"><span class="wpp-views">21.5k views</span></span>
</li>
<li>
<a href="https://waterlandblog.com/2021/10/16/construction-signs-around-des-moines-found-hacked-saturday-morning/" class="wpp-post-title" target="_self">Construction signs around Des Moines found hacked Saturday morning</a>
<span class="wpp-meta post-stats"><span class="wpp-views">13.1k views</span></span>
</li>
<li>
<a href="https://waterlandblog.com/2019/08/27/looks-like-the-historic-landmark-on-the-sound-has-been-sold/" class="wpp-post-title" target="_self">Looks like the historic Landmark on the Sound has been sold</a>
<span class="wpp-meta post-stats"><span class="wpp-views">12k views</span></span>
</li>
<li>
<a href="https://waterlandblog.com/2021/09/26/3-killed-in-shooting-outside-sports-bar-in-des-moines-early-sunday-morning/" class="wpp-post-title" target="_self">3 killed in shooting outside sports bar in Des Moines early Sunday morning</a>
<span class="wpp-meta post-stats"><span class="wpp-views">5.9k views</span></span>
</li>
<li>
<a href="https://waterlandblog.com/2020/02/15/two-teachers-forced-out-of-buriens-kennedy-catholic-high-school-due-to-lgbt-status/" class="wpp-post-title" target="_self">Two teachers forced out of Burien&#8217;s Kennedy Catholic High School due to LGBT status</a>
<span class="wpp-meta post-stats"><span class="wpp-views">5.3k views</span></span>
</li>
<li>
<a href="https://waterlandblog.com/2019/10/27/suspect-wanted-in-connection-with-sexual-assault-found-dead-in-des-moines-creek/" class="wpp-post-title" target="_self">Suspect wanted in connection with sexual assault found dead in Des Moines Creek</a>
<span class="wpp-meta post-stats"><span class="wpp-views">4.3k views</span></span>
</li>
<li>
<a href="https://waterlandblog.com/2020/05/31/man-stabbed-killed-in-domestic-violence-homicide-in-des-moines-saturday-night/" class="wpp-post-title" target="_self">Man stabbed, killed in domestic violence homicide in Des Moines Saturday night</a>
<span class="wpp-meta post-stats"><span class="wpp-views">4.1k views</span></span>
</li>
</ul>
</div> 
<div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='http://kcls.org' rel='external nofollow ugc' class='url'>Yvonne Burkett</a></span> on <a href="https://waterlandblog.com/2022/02/17/united-way-of-king-county-offering-free-in-person-virtual-tax-preparation-services/#comment-137663">United Way of King County offering free in-person/virtual tax preparation services</a></li><li class="recentcomments"><span class="comment-author-link">Yvonne Nutting</span> on <a href="https://waterlandblog.com/2022/03/07/whats-up-des-moines-meet-the-harpers-steve-edmiston-susie-novak/#comment-137148">What&#8217;s Up Des Moines? Meet the Harpers, Steve Edmiston &#038; Susie Novak</a></li><li class="recentcomments"><span class="comment-author-link">Traci buxton</span> on <a href="https://waterlandblog.com/2022/03/07/whats-up-des-moines-meet-the-harpers-steve-edmiston-susie-novak/#comment-137064">What&#8217;s Up Des Moines? Meet the Harpers, Steve Edmiston &#038; Susie Novak</a></li><li class="recentcomments"><span class="comment-author-link">Robert Back</span> on <a href="https://waterlandblog.com/2022/03/04/pennington-appointed-to-des-moines-city-council-seat-through-2023/#comment-136420">Pennington appointed to Des Moines City Council seat through 2023</a></li><li class="recentcomments"><span class="comment-author-link">Sandy</span> on <a href="https://waterlandblog.com/2022/02/25/three-vying-for-des-moines-city-council-vacancy-after-vargas-drops-out/#comment-134621">Three vying for Des Moines City Council vacancy after Vargas drops out</a></li><li class="recentcomments"><span class="comment-author-link">Faith Beatty</span> on <a href="https://waterlandblog.com/2022/02/11/public-to-get-say-in-proposed-demolition-of-iconic-des-moines-masonic-home/#comment-133567">Public to get say in proposed demolition of iconic Des Moines Masonic home</a></li><li class="recentcomments"><span class="comment-author-link">Keith</span> on <a href="https://waterlandblog.com/2022/02/11/public-to-get-say-in-proposed-demolition-of-iconic-des-moines-masonic-home/#comment-132119">Public to get say in proposed demolition of iconic Des Moines Masonic home</a></li></ul></div> <div id="bs_zones-12" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76241" keywords="not_home_page,not_landing_page,is_article_page,arts,burien,business,des-moines,entertainment,events,featured-post,history,news,burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> </div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_3">
<div class="container">
<div class="et_pb_extra_row container-width-change-notify">
<div class="et_pb_extra_column odd column-1">
<div id="rss-2" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget rss-widget-feed" href="http://b-townblog.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://waterlandblog.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget rss-widget-title" href="https://b-townblog.com/">The B-Town (Burien) Blog</a></h4><ul><li><a class='rsswidget' href='https://b-townblog.com/2022/05/10/dal-law-firm-ways-to-build-credit-after-bankruptcy/'>DAL Law Firm: Ways to build credit after Bankruptcy</a></li><li><a class='rsswidget' href='https://b-townblog.com/2022/05/10/southern-heights-elementary-farewell-celebration-will-be-saturday-may-21/'>Southern Heights Elementary Farewell Celebration will be Saturday, May 21</a></li><li><a class='rsswidget' href='https://b-townblog.com/2022/05/10/colin-mccabe-is-a-berkshire-hathaway-homeservices-nw-realty-broker-with-16-years-experience/'>Colin McCabe is a Berkshire Hathaway HomeServices NW Realty Broker with 16 years’ experience</a></li><li><a class='rsswidget' href='https://b-townblog.com/2022/05/09/next-coffee-with-a-cop-event-will-be-at-burien-starbucks-this-friday-may-13/'>Next ‘Coffee with a Cop’ event will be at Burien Starbucks this Friday, May 13</a></li><li><a class='rsswidget' href='https://b-townblog.com/2022/05/09/highline-school-board-to-interview-applicants-for-district-5-director-wed-may-11/'>Highline School Board to interview applicants for District 5 Director Wed., May 11</a></li></ul></div>  </div>
<div class="et_pb_extra_column even column-2">
<div id="rss-4" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget rss-widget-feed" href="http://ilovekent.net/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://waterlandblog.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget rss-widget-title" href="https://www.ilovekent.net/">I Love Kent</a></h4><ul><li><a class='rsswidget' href='https://www.ilovekent.net/2022/05/09/car-crashes-into-kent-panther-lake-library-closing-it-until-further-notice/'>Car crashes into Kent Panther Lake Library, closing it ‘until further notice’</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2022/05/09/kent-community-clean-up-paint-out-graffiti-event-will-be-saturday-june-18/'>Kent Community Clean Up &amp; Paint Out Graffiti event will be Saturday, June 18</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2022/05/09/help-stamp-out-hunger-by-leaving-food-donations-at-your-mailbox-on-sat-may-14/'>Help ‘Stamp Out Hunger’ by leaving food donations at your mailbox on Sat., May 14</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2022/05/06/domestic-violence-shooting-suspect-arrested-after-region-wide-search-starting-in-kent/'>Domestic Violence shooting suspect arrested after region-wide search starting in Kent</a></li><li><a class='rsswidget' href='https://www.ilovekent.net/2022/05/05/blood-donors-still-needed-for-kent-station-pop-up-donor-center/'>Blood Donors still needed for Kent Station Pop-Up Donor Center</a></li></ul></div>  </div>
<div class="et_pb_extra_column even column-4">
<div id="rss-3" class="et_pb_widget widget_rss"><h4 class="widgettitle"><a class="rsswidget rss-widget-feed" href="http://seatacblog.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://waterlandblog.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget rss-widget-title" href="https://seatacblog.com/">The SeaTac Blog</a></h4><ul><li><a class='rsswidget' href='https://seatacblog.com/2022/05/09/highline-school-board-to-interview-applicants-for-district-5-director-wed-may-11/'>Highline School Board to interview applicants for District 5 Director Wed., May 11</a></li><li><a class='rsswidget' href='https://seatacblog.com/2022/05/09/help-stamp-out-hunger-by-leaving-food-donations-at-your-mailbox-on-sat-may-14/'>Help ‘Stamp Out Hunger’ by leaving food donations at your mailbox on Sat., May 14</a></li><li><a class='rsswidget' href='https://seatacblog.com/2022/05/09/residents-invited-to-discuss-veterans-seniors-and-human-services-levy-may-24/'>Residents invited to discuss Veterans, Seniors and Human Services Levy May 24</a></li><li><a class='rsswidget' href='https://seatacblog.com/2022/05/09/call-for-artists-des-moines-memorial-drive-preservation-association-signal-box-project/'>CALL FOR ARTISTS: Des Moines Memorial Drive Preservation Association Signal Box Project</a></li><li><a class='rsswidget' href='https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/'>Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10</a></li></ul></div>  </div>
</div>
</div>
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>

<div id="footer-nav">
<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/waterlandblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/waterlandblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/waterlandblog/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
</li>
</ul>
</div> 
</div>
</div>
</footer>
</div> 
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','arts','burien','business','des-moines','entertainment','events','featured-post','history','news','burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["arts","burien","business","des-moines","entertainment","events","featured-post","history","news","burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14","post"],"url":"burien-ufo-block-party-metaphysical-fair-will-land-at-town-square-park-sat-may-14"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6233);
 });</script><div style="position:fixed;bottom:0px;right:8%;z-index:999999;" id="gtranslate_wrapper">
<style>
.switcher {font-family:Arial;font-size:12pt;text-align:left;cursor:pointer;overflow:hidden;width:173px;line-height:17px;}
.switcher a {text-decoration:none;display:block;font-size:12pt;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;}
.switcher a img {vertical-align:middle;display:inline;border:0;padding:0;margin:0;opacity:0.8;}
.switcher a:hover img {opacity:1;}
.switcher .selected {background:#fff linear-gradient(180deg, #efefef 0%, #fff 70%);position:relative;z-index:9999;}
.switcher .selected a {border:1px solid #ccc;color:#666;padding:3px 5px;width:161px;}
.switcher .selected a:after {height:24px;display:inline-block;position:absolute;right:10px;width:15px;background-position:50%;background-size:11px;background-image:url("data:image/svg+xml;utf8,<svg xmlns='http://www.w3.org/2000/svg' width='16' height='16' viewBox='0 0 285 285'><path d='M282 76.5l-14.2-14.3a9 9 0 0 0-13.1 0L142.5 174.4 30.3 62.2a9 9 0 0 0-13.2 0L3 76.5a9 9 0 0 0 0 13.1l133 133a9 9 0 0 0 13.1 0l133-133a9 9 0 0 0 0-13z' style='fill:%23666'/></svg>");background-repeat:no-repeat;content:""!important;transition:all .2s;}
.switcher .selected a.open:after {-webkit-transform: rotate(-180deg);transform:rotate(-180deg);}
.switcher .selected a:hover {background:#fff}
.switcher .option {position:relative;z-index:9998;border-left:1px solid #ccc;border-right:1px solid #ccc;border-bottom:1px solid #ccc;background-color:#eee;display:none;width:171px;max-height:198px;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;overflow-y:auto;overflow-x:hidden;}
.switcher .option a {color:#000;padding:3px 5px;}
.switcher .option a:hover {background:#fff;}
.switcher .option a.selected {background:#fff;}
#selected_lang_name {float: none;}
.l_name {float: none !important;margin: 0;}
.switcher .option::-webkit-scrollbar-track{-webkit-box-shadow:inset 0 0 3px rgba(0,0,0,0.3);border-radius:5px;background-color:#f5f5f5;}
.switcher .option::-webkit-scrollbar {width:5px;}
.switcher .option::-webkit-scrollbar-thumb {border-radius:5px;-webkit-box-shadow: inset 0 0 3px rgba(0,0,0,.3);background-color:#888;}
</style>
<div class="switcher notranslate">
<div class="selected">
<a href="#" onclick="return false;"><img src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /> English</a>
</div>
<div class="option">
<a href="#" onclick="doGTranslate('en|zh-CN');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Chinese (Simplified)" class="nturl"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/zh-CN.png" height="24" width="24" alt="zh-CN" /> Chinese (Simplified)</a><a href="#" onclick="doGTranslate('en|en');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="English" class="nturl selected"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /> English</a><a href="#" onclick="doGTranslate('en|it');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Italian" class="nturl"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/it.png" height="24" width="24" alt="it" /> Italian</a><a href="#" onclick="doGTranslate('en|es');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Spanish" class="nturl"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/es-mx.png" height="24" width="24" alt="es" /> Spanish</a><a href="#" onclick="doGTranslate('en|uk');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Ukrainian" class="nturl"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/uk.png" height="24" width="24" alt="uk" /> Ukrainian</a><a href="#" onclick="doGTranslate('en|vi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Vietnamese" class="nturl"><img data-gt-lazy-src="//waterlandblog.com/wp-content/plugins/gtranslate/flags/24/vi.png" height="24" width="24" alt="vi" /> Vietnamese</a></div>
</div>
<script>
jQuery('.switcher .selected').click(function() {jQuery('.switcher .option a img').each(function() {if(!jQuery(this)[0].hasAttribute('src'))jQuery(this).attr('src', jQuery(this).attr('data-gt-lazy-src'))});if(!(jQuery('.switcher .option').is(':visible'))) {jQuery('.switcher .option').stop(true,true).delay(100).slideDown(500);jQuery('.switcher .selected a').toggleClass('open')}});
jQuery('.switcher .option').bind('mousewheel', function(e) {var options = jQuery('.switcher .option');if(options.is(':visible'))options.scrollTop(options.scrollTop() - e.originalEvent.wheelDelta/10);return false;});
jQuery('body').not('.switcher').click(function(e) {if(jQuery('.switcher .option').is(':visible') && e.target != jQuery('.switcher .option').get(0)) {jQuery('.switcher .option').stop(true,true).delay(100).slideUp(500);jQuery('.switcher .selected a').toggleClass('open')}});
</script>
<style>#goog-gt-tt{display:none!important;}.goog-te-banner-frame{display:none!important;}.goog-te-menu-value:hover{text-decoration:none!important;}.goog-text-highlight{background-color:transparent!important;box-shadow:none!important;}body{top:0!important;}#google_translate_element2{display:none!important;}</style>
<div id="google_translate_element2"></div>
<script>function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}if(!window.gt_translate_script){window.gt_translate_script=document.createElement('script');gt_translate_script.src='https://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2';document.body.appendChild(gt_translate_script);}</script>
<script>
function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;if(typeof ga=='function'){ga('send', 'event', 'GTranslate', lang, location.hostname+location.pathname+location.search);}var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(sel[i].className.indexOf('goog-te-combo')!=-1){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}
if(GTranslateGetCurrentLang() != null)jQuery(document).ready(function() {var lang_html = jQuery('div.switcher div.option').find('img[alt="'+GTranslateGetCurrentLang()+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));});
</script>
<script>(function gt_jquery_ready() {if(!window.jQuery||!jQuery.fn.click) return setTimeout(gt_jquery_ready, 20);jQuery(document).ready(function() {var allowed_languages = ["zh-CN","en","it","es","uk","vi"];var accept_language = navigator.language.toLowerCase() || navigator.userLanguage.toLowerCase();switch(accept_language) {case 'zh-cn': var preferred_language = 'zh-CN'; break;case 'zh': var preferred_language = 'zh-CN'; break;case 'zh-tw': var preferred_language = 'zh-TW'; break;case 'zh-hk': var preferred_language = 'zh-TW'; break;case 'he': var preferred_language = 'iw'; break;default: var preferred_language = accept_language.substr(0, 2); break;}if(preferred_language != 'en' && GTranslateGetCurrentLang() == null && document.cookie.match('gt_auto_switch') == null && allowed_languages.indexOf(preferred_language) >= 0){doGTranslate('en|'+preferred_language);document.cookie = 'gt_auto_switch=1; expires=Thu, 05 Dec 2030 08:08:08 UTC; path=/;';var lang_html = jQuery('div.switcher div.option').find('img[alt="'+preferred_language+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));}});})();</script></div> <script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script type="text/javascript">
			</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script> window._peq = window._peq || []; window._peq.push(["init"]); </script>
<script src="https://clientcdn.pushengage.com/core/29aaca4d-ef6e-4d3e-833c-bb5dbbd8.js" async></script><link rel='stylesheet' id='tec-variables-skeleton-css' href='https://waterlandblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/variables-skeleton.min.css?ver=4.14.18.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-skeleton-style-css' href='https://waterlandblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.14.18.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-widgets-v2-events-list-skeleton-css' href='https://waterlandblog.com/wp-content/plugins/the-events-calendar/src/resources/css/widget-events-list-skeleton.min.css?ver=5.14.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='tec-variables-full-css' href='https://waterlandblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/variables-full.min.css?ver=4.14.18.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-full-style-css' href='https://waterlandblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-full.min.css?ver=4.14.18.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-widgets-v2-events-list-full-css' href='https://waterlandblog.com/wp-content/plugins/the-events-calendar/src/resources/css/widget-events-list-full.min.css?ver=5.14.2.1' type='text/css' media='all' />
<script type='text/javascript' id='pushengage-core-js-before'>
window._peq = window._peq || []; window._peq.push(['init']);
</script>
<script type='text/javascript' async src='https://clientcdn.pushengage.com/core/29aaca4d-ef6e-4d3e-833c-bb5dbbd8.js?ver=5.9.3' id='pushengage-core-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.13.1' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/dist/dom-ready.min.js?ver=ecda74de0221e1c2ce5c57cbb5af09d5' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/dist/hooks.min.js?ver=1e58c8c5a32b2e97491080c5b10dc71c' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/dist/i18n.min.js?ver=30fcecb428a0e8383d3776bcdd3a7834' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/dist/a11y.min.js?ver=68e470cf840f69530e9db3be229ad4b6' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.13.1' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/waterlandblog.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/images\/","ajaxurl":"https:\/\/waterlandblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"c0286d5561","timeline_nonce":"ca21c63d93","blog_feed_nonce":"806ba65391","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/waterlandblog.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/images","builder_images_uri":"https:\/\/waterlandblog.com\/wp-content\/themes\/Extra-2\/includes\/builder\/images","et_frontend_nonce":"84de1910db","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"d70c154d54","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"140908","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://waterlandblog.com/wp-content/themes/Extra-2/scripts/scripts.min.js?ver=2.27.4' id='extra-scripts-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1641922093' id='zoom-social-icons-widget-frontend-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-content/themes/Extra-2/core/admin/js/common.js?ver=3.27.4' id='et-core-common-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/tribe-common.min.js?ver=4.14.18.1' id='tribe-common-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/utils/query-string.js?ver=4.14.18.1' id='tribe-query-string-js'></script>
<script src='https://waterlandblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script src='https://waterlandblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script>
<script defer type='text/javascript' src='https://waterlandblog.com/wp-content/plugins/the-events-calendar/src/resources/js/views/manager.js?ver=5.14.2.1' id='tribe-events-views-v2-manager-js'></script>
<script type='text/javascript' src='https://waterlandblog.com/wp-content/plugins/the-events-calendar/src/resources/js/views/breakpoints.js?ver=5.14.2.1' id='tribe-events-views-v2-breakpoints-js'></script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://waterlandblog.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<button class="play" aria-label="play Youtube video"></button>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.parentNode.dataset.query.length?'':'&'+this.parentNode.dataset.query;e.setAttribute("src",t.replace("ID",this.parentNode.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.parentNode.replaceChild(e,this.parentNode)}document.addEventListener("DOMContentLoaded",function(){var e,t,p,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),a[t].appendChild(e),p=e.querySelector('.play'),p.onclick=lazyLoadYoutubeIframe});</script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'70958f8368d58203',m:'LiI3Vb953KhLC8_miuDfW8C0rzLGukMkedouK81llBk-1652215967-0-AX9n2Ir/ebd4tBHIQA4C1vRSxqWyOgQAcwxk2rS157u/TxxdlkFphFw34cPZAKBHzg01AMaEThT9mv5DBYFUGty8/R8uJtHYjMibn6wgtblkHPBQyHKFgU42ODzhd0GWR0R3asOAzK1fI91xFMoxkOVSh/GNMyFMDmU4UU9qQOtTxLbfm3hYGuN8JcOUVUdinIDa22cbEzD4up4MzwuUleE9bU0ZWFDQt5vwok6NHCFW',s:[0x571cf76e35,0x3c2a89fe23],u:'/cdn-cgi/challenge-platform/h/b'}})();</script></body>
</html>
